Jump to content



Photo

Error with new installation


  • Please log in to reply
1 reply to this topic

#1   mmdona

mmdona
  • Members
  • 5 posts
  • Real Name:Molly Donaldson

Posted 13 June 2010 - 03:09

I've just installed oscommerce-2.2rc2a and STS (no other add-ons). I installed the Authorize.net SIM module, put in my correct information (I double-checked), and then tried to process an order (I put my authorize.net account into test mode). The shopping cart allowed me to select the Credit Card (Processed by Authorize.net) on the payment information step and then it sent me to the confirmation step (never asking for a credit card number, mind you). On the Confirmation step I pressed the confirm order button and was greeted with a page that says "The following errors have occurred. (14) The referrer, relay response or receipt link URL is invalid." Store is at http://www.AJSportsZone.com/catalog.

I'm sure I must have missed something, but can't tell what.

More settings:
Transaction Server = live
Transaction Mode = live
Transaction Method = capture
Payment Zone = none
Set Order Status = processing

Thanks!!!

#2   Padams7

Padams7
  • Members
  • 6 posts
  • Real Name:Phil

Posted 15 June 2010 - 14:39

Double check your Login ID, and Transaction Key - and I have Enable Authorize.net Credit Card SIM, True

Also, have you set up yor MD5 Hash?

I have my orders still set to Pending - but thats basically it, all my other information is as yours is.

My payments are working fine, and going through, EXCEPT, when it redirects them to my checkoutsuccess.php I get the broken images (see other thread about it)

The only thing I am thinking, was when I set mine up, I never went into "test mode" @ Authorize.net - I just made a product cost $1.00 and added 5 cents shipping and gave it a few shots on my credit card, then voided them in the a.net control panel.