Jump to content



Photo
* * * * * 1 votes

Automatic Trigger Email Campaigns with MailBeez Modules


  • Please log in to reply
495 replies to this topic

#41   sublok

sublok
  • Members
  • 28 posts
  • Real Name:J
  • Gender:Male

Posted 12 July 2010 - 16:28

FYI: It appears that the cron job in question, which is executing the mailhive.php file, requires HTTP sessions. Such sessions will not be available within a cron job. Additioanlly, if the script is calling for server_status information, this information will also be unavailable. We recommend checking your script and ensuring that HTTP sessions and server_status calls are not required by the script.

Hows it going on that silent mailhive?

Edited by sublok, 12 July 2010 - 16:34.


#42   floydax

floydax
  • Members
  • 19 posts
  • Real Name:floyd

Posted 16 July 2010 - 12:06

Hi,

First of all, thanks for this great contribution.

On the first post you mentioned a Payment Reminder module, but I can't to seem to find it. Is it available or is it still on development?


Regards,
floydax

#43   analogixx

analogixx
  • Members
  • 12 posts
  • Real Name:Mario Weiler

Posted 16 July 2010 - 14:18

Hi,
I did the first step of installation in an oscommerce environment.

After setting up all files and pressing the link in the toolbox the system tries to open this URL:
http://www.mydomain.de/admin/mailbeez.php?osCAdminID=6ed812fcd219b04a81c27e5febdb88bd

and I get that opened:
admin/FILENAME_FORBIDEN?osCAdminID=6ed812fcd219b04a81c27e5febdb88bd

with the error 404 file not found.
I had this in another contrib as well and still does not know, why this happens.

can you help ?
All files are there, the authority is o.k.
thanks

M@rio

#44   analogixx

analogixx
  • Members
  • 12 posts
  • Real Name:Mario Weiler

Posted 16 July 2010 - 14:26

when I try to open the /admin/mailbeez.php the oscommerce admin login screen pops up. When I log in, I get the normal administration page.

#45   analogixx

analogixx
  • Members
  • 12 posts
  • Real Name:Mario Weiler

Posted 16 July 2010 - 15:17

o.k. there the file was not registered.

What I get in the admin menu is now:

Access Denied

I changed ALL files to full access. Still

#46   ricardodacosta

ricardodacosta
  • Members
  • 132 posts
  • Real Name:ricardo

Posted 16 July 2010 - 19:12

Hello, thank you for such wonderful idea/addon

I had no problem installing it and added all the modules so far released. However if I click on "View Mail (Html or Text" a popup shows blank.

Any ideas why this may be happening?

Thanks!

Ricardo

#47   MailBeez

MailBeez
  • Partner
  • 237 posts
  • Real Name:Cord
  • Gender:Male
  • Location:Denmark

Posted 16 July 2010 - 21:08

FYI: It appears that the cron job in question, which is executing the mailhive.php file, requires HTTP sessions. Such sessions will not be available within a cron job. Additioanlly, if the script is calling for server_status information, this information will also be unavailable. We recommend checking your script and ensuring that HTTP sessions and server_status calls are not required by the script.

Hows it going on that silent mailhive?

Hi sublok,

How do you call the cronjob? Do you use an external service? You might need to try a different service, please post if you succed.

It defently works with "lynx ..." like you can see in the documentation.

Am currently on holidays, but hope to find some time soon for the silent mode.

Cord

#48   MailBeez

MailBeez
  • Partner
  • 237 posts
  • Real Name:Cord
  • Gender:Male
  • Location:Denmark

Posted 16 July 2010 - 21:17

o.k. there the file was not registered.

What I get in the admin menu is now:

Access Denied

I changed ALL files to full access. Still


Hi analogixx,

Your issues are not related to mailbeez but I guess you have some kind of admin access rights (must be a mod) you need to set.

Holiday greetings
Cord

#49   MailBeez

MailBeez
  • Partner
  • 237 posts
  • Real Name:Cord
  • Gender:Male
  • Location:Denmark

Posted 16 July 2010 - 21:17

Hi,

First of all, thanks for this great contribution.

On the first post you mentioned a Payment Reminder module, but I can't to seem to find it. Is it available or is it still on development?


Regards,
floydax


Hi floyd,

A payment reminder is under dev. My first post was just a list of ideas.

What would you expect from a payment reminder?

Holiday greetings
Cord

#50   MailBeez

MailBeez
  • Partner
  • 237 posts
  • Real Name:Cord
  • Gender:Male
  • Location:Denmark

Posted 16 July 2010 - 21:18

Hello, thank you for such wonderful idea/addon

I had no problem installing it and added all the modules so far released. However if I click on "View Mail (Html or Text" a popup shows blank.

Any ideas why this may be happening?

Thanks!

Ricardo


Hi ricardodacosta,

Ceebox does show blank when the content is gzip compressed (took me a couple hours to figure out...)

Check if your storefront where mailhive.php is located uses gzip - I tried to override the gzip compression setting in the code but you might have a different setting.

Holiday greetings
Cord

#51   MailBeez

MailBeez
  • Partner
  • 237 posts
  • Real Name:Cord
  • Gender:Male
  • Location:Denmark

Posted 16 July 2010 - 21:18

Hi,

First of all, thanks for this great contribution.

On the first post you mentioned a Payment Reminder module, but I can't to seem to find it. Is it available or is it still on development?


Regards,
floydax


Hi floyd,

A payment reminder is under dev. My first post was just a list of ideas.

What would you expect from a payment reminder?

Holiday greetings
Cord

#52   ricardodacosta

ricardodacosta
  • Members
  • 132 posts
  • Real Name:ricardo

Posted 17 July 2010 - 13:03

Hi ricardodacosta,

Ceebox does show blank when the content is gzip compressed (took me a couple hours to figure out...)

Check if your storefront where mailhive.php is located uses gzip - I tried to override the gzip compression setting in the code but you might have a different setting.

Holiday greetings
Cord



I do have Gzip enable under Configurations with a Level 5. I turn it off just to try but that didn't help...I am not able to see the content as a popup. I did notice that if I click on the button that says "check for update" that content does show up or if I opened any of the links on a different window, it shows up also.

Any other suggestions?

Thanks!

Ricardo

#53   MailBeez

MailBeez
  • Partner
  • 237 posts
  • Real Name:Cord
  • Gender:Male
  • Location:Denmark

Posted 17 July 2010 - 20:11

I do have Gzip enable under Configurations with a Level 5. I turn it off just to try but that didn't help...I am not able to see the content as a popup. I did notice that if I click on the button that says "check for update" that content does show up or if I opened any of the links on a different window, it shows up also.

Any other suggestions?

Thanks!

Ricardo


Sounds like MailBeez is running correctly except the ceebox popups.

The content of the update-check is coming from www.mailbeez.com, the content of the other ceebox-popups from http://yourserver/mailhive.php

Try to tripple-check if your server is using http gzip compression - can't currently think of another reason...

Please keep me up-to-date if you find out what is wrong. I will probably need to build in an alternative to the nice ceebox-popups...

Cord

#54   AWOP

AWOP
  • Members
  • 11 posts
  • Real Name:Pie Monkey

Posted 18 July 2010 - 09:10

Hello - I have just installed this plugin for zen-cart and I am getting the same problem (blank page).
I have gzip disabled and have checked it using a website which says it is not running. (http://www.whatsmyip...tp_compression/)

I had a few problems following the install instructions :-
Instructions say "includes/extra_boxes/mailbeez_tools_dhtml.php" However its in folder "includes/boxes/extra_boxes/mailbeez_tools_dhtml.php" Where should this file be placed?

Regards,
Tim.



Hello, thank you for such wonderful idea/addon

I had no problem installing it and added all the modules so far released. However if I click on "View Mail (Html or Text" a popup shows blank.

Any ideas why this may be happening?

Thanks!

Ricardo



#55   MailBeez

MailBeez
  • Partner
  • 237 posts
  • Real Name:Cord
  • Gender:Male
  • Location:Denmark

Posted 18 July 2010 - 12:33

Hello - I have just installed this plugin for zen-cart and I am getting the same problem (blank page).
I have gzip disabled and have checked it using a website which says it is not running. (http://www.whatsmyip...tp_compression/)

I had a few problems following the install instructions :-
Instructions say "includes/extra_boxes/mailbeez_tools_dhtml.php" However its in folder "includes/boxes/extra_boxes/mailbeez_tools_dhtml.php" Where should this file be placed?

Regards,
Tim.

Hi Tim & ricardo,

I can't replicate the problem since in my environments everything works, hope we can figure it out together. Am on holidays until start of august, but maybe we can locate the reason.

The ceebox popup is using dhtml/Ajax - the issue must somewhere be related to this.

What OS / Browser are you using? Have you tried a different browser?

What Server are you using?

The blank area in the ceebox popup should be an iframe. What do you get from right click > iframe properties / source?

Since the update check is working I assume the issue is not related to http/https - can you confirm this?

Try to change the html doc-type in catalog/mailhive.php to the same value as the update-check uses (source code). (had before some issues with ceebox in IE due to doc-type)

If you want you can deactivate the ceebox popups by commenting the ceebox.js out in the mailbeez admin. The buttons will then open in a new tab/window.

@Tim:
I will check the install docs when back. Put the extra-box in the existing tools extra_boxes folder (hope I remember correctly). It will put the MailBeez link in your admin/tools menue.

Cord

#56   samar777

samar777
  • Members
  • 1 posts
  • Real Name:Samar

Posted 18 July 2010 - 15:04

Hiii, I installed the module on my zen cart.

I am having a little trouble in getting it to work.

When I run the module, or click on "list recipients" ...nothing shows up.

I get this:

MailBeez - Mode: production

Processing....
code: nopurchase module: nopurchase
Result:0 items

I truly appreciate your help in advance as I want to get working with the great contribution asap.

Thanks

#57   MailBeez

MailBeez
  • Partner
  • 237 posts
  • Real Name:Cord
  • Gender:Male
  • Location:Denmark

Posted 18 July 2010 - 15:54

Hiii, I installed the module on my zen cart.

I am having a little trouble in getting it to work.

When I run the module, or click on "list recipients" ...nothing shows up.

I get this:

MailBeez - Mode: production

Processing....
code: nopurchase module: nopurchase
Result:0 items

I truly appreciate your help in advance as I want to get working with the great contribution asap.

Thanks

I would say everything is fine and the module does what it should - you just have no customers w/o a purchase with their account created in the given timeframe.

Try to set the "skip after" number of days to a high number or create an account and set the start number of days to -1

Cord

#58   pctekcomponents

pctekcomponents
  • Members
  • 46 posts
  • Real Name:Steven
  • Gender:Male
  • Location:Scotland

Posted 19 July 2010 - 21:55

This might be a dumb question but i haven't been able to find any info.

Is there a way to limit the number of emails sent?

My host doesn't allow any more than 30 emails per 5 minutes and a total of 100 emails per hour.

Any help would be appreciated.

Edited by pctekcomponents, 19 July 2010 - 21:56.


#59   MailBeez

MailBeez
  • Partner
  • 237 posts
  • Real Name:Cord
  • Gender:Male
  • Location:Denmark

Posted 20 July 2010 - 09:48

This might be a dumb question but i haven't been able to find any info.

Is there a way to limit the number of emails sent?

My host doesn't allow any more than 30 emails per 5 minutes and a total of 100 emails per hour.

Any help would be appreciated.


There are no dumb questions /wink.gif' class='bbc_emoticon' alt=';)' />

Email throtling is a future feature (but can't give you a date).

Please use the floating "feedback" (left) on mailbeez.com to vote for or request a feature.

Cord

#60   pctekcomponents

pctekcomponents
  • Members
  • 46 posts
  • Real Name:Steven
  • Gender:Male
  • Location:Scotland

Posted 20 July 2010 - 10:22

ok thanks. I'll do that.

Shame i'll have to wait on that before i can use this excellent contrib.