Jump to content



Photo
- - - - -

Doesn't work on IE


This topic has been archived. This means that you cannot reply to this topic.
15 replies to this topic

#1   DiViN3

DiViN3
  • Members
  • 19 posts

Posted 05 December 2009 - 18:56

Why dos it work on FF but not on IE?

http://www.salvia-fl...norum/index.php

#2   germ

germ
  • Members
  • 13,921 posts

Posted 05 December 2009 - 18:59

Why dos it work on FF but not on IE?

http://www.salvia-fl...norum/index.php

Looking at the source code for the page:

<base href="">
The configure file is incorrect.

FF is smart enough to overcome this.

IE isn't.
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#3   DiViN3

DiViN3
  • Members
  • 19 posts

Posted 05 December 2009 - 19:15

sry 4 this stupid question, but:
where ist this file located?

#4   germ

germ
  • Members
  • 13,921 posts

Posted 05 December 2009 - 19:17

/shop/salviadivinorum/includes/configure.php
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#5   FWR Media

FWR Media
  • Members
  • 6,839 posts

Posted 05 December 2009 - 19:28

/shop/salviadivinorum/includes/configure.php


The important bits to your problem are ..

define('HTTP_SERVER', 'http://www.mysite.com');
  define('HTTPS_SERVER', 'http://www.mysite.com');
  define('ENABLE_SSL', false);
  define('HTTP_COOKIE_DOMAIN', 'www.mysite.com');
  define('HTTPS_COOKIE_DOMAIN', 'www.mysite.com');
  define('HTTP_COOKIE_PATH', '/');
  define('HTTPS_COOKIE_PATH', '/');
  define('DIR_WS_HTTP_CATALOG', '/');
  define('DIR_WS_HTTPS_CATALOG', '/');

the last four enties with / will be different dependent on where your site is located e.g.

If you access your site as ..

http:www.mysite.com/ the setting is /

http:www.mysite.com/catalog/ the setting is /catalog/

http:www.mysite.com/catalog/shop/ the setting is /catalog/shop/

Edited by FWR Media, 05 December 2009 - 19:32.


#6   DiViN3

DiViN3
  • Members
  • 19 posts

Posted 05 December 2009 - 19:28

.

Edited by DiViN3, 05 December 2009 - 19:32.


#7   germ

germ
  • Members
  • 13,921 posts

Posted 05 December 2009 - 19:34

OK, then I had the correct file, but I still don't see where's ther problem. Sorry /blush.gif' class='bbc_emoticon' alt=':blush:' />

In addition to what Robert posted, this might help:

A Guide to the configure files
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#8   DiViN3

DiViN3
  • Members
  • 19 posts

Posted 05 December 2009 - 19:55

Thanks for your quick help! /thumbsup.gif' class='bbc_emoticon' alt=':thumbsup:' />

I tried some things and read the other post. I also made some changes, but it won't work.
The last try lookd like this:

define('HTTP_COOKIE_PATH', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('HTTPS_COOKIE_PATH', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('DIR_WS_HTTP_CATALOG', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('DIR_WS_HTTPS_CATALOG', 'www.salvia-flash.ch/shop/salviadivinorum');

I thinik I'll make a try later on. I worked 2 much today.... /blink.gif' class='bbc_emoticon' alt=':blink:' />
Now I know why I just use FF and not IE /wink.gif' class='bbc_emoticon' alt=';)' />

#9   germ

germ
  • Members
  • 13,921 posts

Posted 05 December 2009 - 19:59

Thanks for your quick help! /thumbsup.gif' class='bbc_emoticon' alt=':thumbsup:' />

I tried some things and read the other post. I also made some changes, but it won't work.
The last try lookd like this:

define('HTTP_COOKIE_PATH', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('HTTPS_COOKIE_PATH', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('DIR_WS_HTTP_CATALOG', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('DIR_WS_HTTPS_CATALOG', 'www.salvia-flash.ch/shop/salviadivinorum');

I thinik I'll make a try later on. I worked 2 much today.... /blink.gif' class='bbc_emoticon' alt=':blink:' />
Now I know why I just use FF and not IE /wink.gif' class='bbc_emoticon' alt=';)' />

From what I can tell you haven't successfully changed ALL of what Robert suggested.

Also be aware of this:

In the includes FOLDER (catalog and admin) where the normal configure.php files are there is a FOLDER named local

On some installs there may be a configure.php inside the local FOLDER (catalog and admin)

If there is, anything in it overrides anything in the normal configure.php files.
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#10   FWR Media

FWR Media
  • Members
  • 6,839 posts

Posted 05 December 2009 - 20:12

Thanks for your quick help! /thumbsup.gif' class='bbc_emoticon' alt=':thumbsup:' />

I tried some things and read the other post. I also made some changes, but it won't work.
The last try lookd like this:

define('HTTP_COOKIE_PATH', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('HTTPS_COOKIE_PATH', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('DIR_WS_HTTP_CATALOG', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('DIR_WS_HTTPS_CATALOG', 'www.salvia-flash.ch/shop/salviadivinorum');

I thinik I'll make a try later on. I worked 2 much today.... /blink.gif' class='bbc_emoticon' alt=':blink:' />
Now I know why I just use FF and not IE /wink.gif' class='bbc_emoticon' alt=';)' />


Well as Jim stated not only have you not implemented the changes but you seemed to have ignored the advice.

define('HTTP_COOKIE_PATH', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('HTTPS_COOKIE_PATH', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('DIR_WS_HTTP_CATALOG', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('DIR_WS_HTTPS_CATALOG', 'www.salvia-flash.ch/shop/salviadivinorum');

Is nothing like I suggested .. perhaps based on what you have there ..

define('HTTP_COOKIE_PATH', 'www.salvia-flash.ch');
  define('HTTPS_COOKIE_PATH', 'www.salvia-flash.ch');
  define('HTTP_COOKIE_PATH', '/shop/salviadivinorum/');
  define('HTTPS_COOKIE_PATH', '/shop/salviadivinorum/');
  define('DIR_WS_HTTP_CATALOG', '/shop/salviadivinorum/');
  define('DIR_WS_HTTPS_CATALOG', '/shop/salviadivinorum/');

Edited by FWR Media, 05 December 2009 - 20:16.


#11   DiViN3

DiViN3
  • Members
  • 19 posts

Posted 05 December 2009 - 22:04

Good news: The main page is now visible in the IE.
Bad news: The rest of the page is not visible (FF and IE).

As you perhaps know, the link is incorrect :/

http://www.salvia-fl...rum/privacy.php
http://www.salvia-fl...alviadivinorum/salvia-flash.ch/shop/salviadivinorum/privacy.php

The file looks bow like this:
define('HTTP_COOKIE_DOMAIN', '/');
define('HTTPS_COOKIE_DOMAIN', '/');
define('HTTP_COOKIE_PATH', '/');
define('HTTPS_COOKIE_PATH', '/');
define('DIR_WS_HTTP_CATALOG', 'salvia-flash.ch/shop/salviadivinorum/');
define('DIR_WS_HTTPS_CATALOG', 'salvia-flash.ch/shop/salviadivinorum/');


I think I tried every cominiation, still won't work.

@ FWR Media:

Ist this really correct? Do I have to define this tiwce?

define('HTTP_COOKIE_PATH', 'www.salvia-flash.ch');
  define('HTTPS_COOKIE_PATH', 'www.salvia-flash.ch');
  define('HTTP_COOKIE_PATH', '/shop/salviadivinorum/');
  define('HTTPS_COOKIE_PATH', '/shop/salviadivinorum/');



This didn't work for me:

define('DIR_WS_HTTP_CATALOG', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('DIR_WS_HTTPS_CATALOG', 'www.salvia-flash.ch/shop/salviadivinorum');
It worked without the www infront.


Hmmm...

#12   FWR Media

FWR Media
  • Members
  • 6,839 posts

Posted 05 December 2009 - 22:42

Good news: The main page is now visible in the IE.
Bad news: The rest of the page is not visible (FF and IE).

As you perhaps know, the link is incorrect :/

http://www.salvia-fl...rum/privacy.php
http://www.salvia-fl...alviadivinorum/salvia-flash.ch/shop/salviadivinorum/privacy.php

The file looks bow like this:

define('HTTP_COOKIE_DOMAIN', '/');
define('HTTPS_COOKIE_DOMAIN', '/');
define('HTTP_COOKIE_PATH', '/');
define('HTTPS_COOKIE_PATH', '/');
define('DIR_WS_HTTP_CATALOG', 'salvia-flash.ch/shop/salviadivinorum/');
define('DIR_WS_HTTPS_CATALOG', 'salvia-flash.ch/shop/salviadivinorum/');


I think I tried every cominiation, still won't work.

@ FWR Media:

Ist this really correct? Do I have to define this tiwce?

define('HTTP_COOKIE_PATH', 'www.salvia-flash.ch');
  define('HTTPS_COOKIE_PATH', 'www.salvia-flash.ch');
  define('HTTP_COOKIE_PATH', '/shop/salviadivinorum/');
  define('HTTPS_COOKIE_PATH', '/shop/salviadivinorum/');



This didn't work for me:

define('DIR_WS_HTTP_CATALOG', 'www.salvia-flash.ch/shop/salviadivinorum');
  define('DIR_WS_HTTPS_CATALOG', 'www.salvia-flash.ch/shop/salviadivinorum');
It worked without the www infront.


Hmmm...


No I'm just getting tired of writing the same things and made an error.

  define('HTTP_SERVER', 'http://www.salvia-flash.ch');
  define('HTTPS_SERVER', 'http://www.salvia-flash.ch');
  define('ENABLE_SSL', false);
  define('HTTP_COOKIE_DOMAIN', 'www.salvia-flash.ch');
  define('HTTPS_COOKIE_DOMAIN', 'www.salvia-flash.ch');
  define('HTTP_COOKIE_PATH', '/shop/salviadivinorum/');
  define('HTTPS_COOKIE_PATH', '/shop/salviadivinorum/');
  define('DIR_WS_HTTP_CATALOG', '/shop/salviadivinorum/');
  define('DIR_WS_HTTPS_CATALOG', '/shop/salviadivinorum/');


#13   DiViN3

DiViN3
  • Members
  • 19 posts

Posted 05 December 2009 - 22:58

It works now. Thanks a lot!!
Sorry for the cirumstances....

#14   wiseword@alice.it

wiseword@alice.it
  • Members
  • 19 posts

Posted 14 May 2012 - 17:19

I'm having the same problem.
Works in IE with both cookies paths set to www.myserver
but not in chrome.
In chrome it works only as '' (with nothing specified.
This is what I have:

define('HTTP_SERVER', 'http://www.edilaudere.com');
define('HTTPS_SERVER', 'http://www.edilaudere.com');
define('ENABLE_SSL', false);
define('HTTP_COOKIE_DOMAIN', '');
define('HTTPS_COOKIE_DOMAIN', '');
define('HTTP_COOKIE_PATH', '/grassfed/catalog/');
define('HTTPS_COOKIE_PATH', '/grassfed/catalog/');
define('DIR_WS_HTTP_CATALOG', '/grassfed/catalog/');
define('DIR_WS_HTTPS_CATALOG', '/grassfed/catalog/');
Can anyone tell me what I am missing. I tried all kinds of things on the cookie path, since that seems to be the problem. There is nothing in my local folder.

#15   germ

germ
  • Members
  • 13,921 posts

Posted 14 May 2012 - 20:31

These:

define('HTTP_COOKIE_DOMAIN', '');
define('HTTPS_COOKIE_DOMAIN', '');


Need to be this:

define('HTTP_COOKIE_DOMAIN', 'www.edilaudere.com');
define('HTTPS_COOKIE_DOMAIN', 'www.edilaudere.com');

Or this:

define('HTTP_COOKIE_DOMAIN', '.edilaudere.com');
define('HTTPS_COOKIE_DOMAIN', '.edilaudere.com');

The path is OK.
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#16   wiseword@alice.it

wiseword@alice.it
  • Members
  • 19 posts

Posted 16 May 2012 - 18:33

Thanks a lot Jim. Unfortunately ( '') and ( '.edilaudere.com' ) works in Chrome.........not in ie.
the only thing that works in ie is' www.edilaudere'
I cannot find anything that works in both. I've tried the slash before, slash after, with http........nothing.
What can it be?