Jump to content



Photo
- - - - -

SSL Implementation Help


This topic has been archived. This means that you cannot reply to this topic.
414 replies to this topic

#341   germ

germ
  • Members
  • 13,921 posts

Posted 30 December 2011 - 02:10

The HTTPS_COOKIE_DOMAIN is wrong.

Try this:

  define('HTTPS_COOKIE_DOMAIN', '.loopiasecure.com');



But you have other problems.

The store isn't recognizing that SSL is "on", it happens a lot with shared SSL.

In the second post in this thread is a link to a contribution I wrote to help fix this.

Download it, unzip it, and upload the files to your shop.

Then let me know so I can access them and see what we need to change.
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#342   addeaz

addeaz
  • Members
  • 70 posts

Posted 03 January 2012 - 17:28

Hi,
Thank you for your help, I did the cookie change!
The contribution is installed, hard for me to see if it tells that something is wrong:)

When I try to log in to the website and SSL is on, I'm landing to this page "https://kameraexpert....com/index.php", but Im not loged in to the site. When SSL is off I get logged in as normal.


Thank you for helping!

Best Regards
Andreas

Edited by addeaz, 03 January 2012 - 17:39.


#343   germ

germ
  • Members
  • 13,921 posts

Posted 04 January 2012 - 11:42

In /includes/application_top.php change this code:

  $request_type = (getenv('SERVER_PORT') == 'on') ? 'SSL' : 'NONSSL';



To:

  $request_type = (getenv('SERVER_PORT') == '443') ? 'SSL' : 'NONSSL';


If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#344   addeaz

addeaz
  • Members
  • 70 posts

Posted 04 January 2012 - 21:05

Hi Germ,
Great that fixed the problem......big thanks, you are the best!!

Best Regards
Andreas

#345   germ

germ
  • Members
  • 13,921 posts

Posted 04 January 2012 - 22:58

I'm glad the SSL part is working.

Just an "FYI" your iframe to facebook is giving the infamous "non secure items" popup in IE.

You can't load content (images, scripts, iframes, etc.) from http sources on https pages.
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#346   addeaz

addeaz
  • Members
  • 70 posts

Posted 04 January 2012 - 23:23

Hi again Germ,
Ok, so it is that iframe that gives me that popup in IE, thanks for that information. /smile.png' class='bbc_emoticon' alt=':)' />

- Is it possible to adjust this in the script so I skip that infamous popup and still can show the Facebooks likes? Maybe is it possible to load that frames script from a https Facebook source?
- This popup is shown at all SSL active pages, how do I turn of SSL in some of the pages (I dont like that the shared URL is shown more than necessary)

Best regards
Andreas

#347   addeaz

addeaz
  • Members
  • 70 posts

Posted 05 January 2012 - 00:00

Hi /smile.png' class='bbc_emoticon' alt=':)' />
I did notice that I could change the likebox URL to https fairly easy. So the pop up is gone:)

Now I will see if I find out how to get the checkout page non SSL.

Best Regards
Andreas

#348   germ

germ
  • Members
  • 13,921 posts

Posted 05 January 2012 - 11:46

Your "LiveZilla.net Chat Button Link Code" is still giving the "unsecure content" warning in IE.

There is a post in this thread that shows how to not display "unsecure" content on SSL pages if you look.
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#349   addeaz

addeaz
  • Members
  • 70 posts

Posted 09 January 2012 - 21:38

Hi Germ,
Thanks again, I fixed that one too (on my live site).

SSL is on and it works, something is a bit strange though;

When I enter the pages where SSL is turned on, the web site get a bit smaller, the texts, frames and so on. Not much, but it is noticable.

Please help me if you have any clue about this one:)

Cheers,

Best Regards
Andreas

#350   germ

germ
  • Members
  • 13,921 posts

Posted 09 January 2012 - 23:52

Now your "Online Support" button/code is giving the "unsecure items" pop-up.
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#351   addeaz

addeaz
  • Members
  • 70 posts

Posted 10 January 2012 - 18:05

Hi Germ,
I guess I fixedit to be ok, on www.StylingAgenten.se, where the Live - site is. I don't get that pop-up, please reply if you do:)

Best Regards
Andreas

#352   patrickluursema

patrickluursema
  • Members
  • 41 posts

Posted 22 January 2012 - 11:32

Got it figured out thanks to this thread. Thanks a lot.
Regards,

Patrick Luursema

#353   Jeff Marincel

Jeff Marincel
  • Members
  • 5 posts

Posted 20 February 2012 - 03:43

I'm having issues with my SSL staying locked, When I go to login, or Cart Checkout, etc. where SSL should be locked. The page starts out locked but then is unlocked even though the address still show https Why is this doing this and what can I do to correct.

#354   DunWeb

DunWeb

    The Censored One

  • Members
  • 13,084 posts

Posted 20 February 2012 - 04:03

@Jeff Marincel

Did you modify the checkout pages ?



Chris
:|: Was this post helpful ? Click the LIKE THIS button :|:

See my Profile to learn more about add ons, templates, support plans and custom coding (click here)

#355   germ

germ
  • Members
  • 13,921 posts

Posted 20 February 2012 - 11:31

You probably have "unsecure content" (i.e. scripts or images loaded from http sources on the https pages)

My guess is your main browser is probably Firefox.

Try using Internet Explorer. My guess is you'll get the infamous "unsecure content" warning.
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#356   Jeff Marincel

Jeff Marincel
  • Members
  • 5 posts

Posted 20 February 2012 - 17:21

I'm not getting any Unseruce Content warnings, and I don't remember modifying my checkout pages. I've tried this on pretty much all browsers with the same results.

#357   germ

germ
  • Members
  • 13,921 posts

Posted 20 February 2012 - 17:40

Can't offer any more help without the URL (posted or by PM).
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#358   Jeff Marincel

Jeff Marincel
  • Members
  • 5 posts

Posted 20 February 2012 - 19:25

In Catalog/includes/configure.php I changed
define('HTTP_SERVER', 'http://mydomain.com');

to

define('HTTP_SERVER', 'https://mydomain.com');

Now everypage is locked but at least the login and checkout stay locked this way.

#359   germ

germ
  • Members
  • 13,921 posts

Posted 21 February 2012 - 11:07

I can't help debug the problem with your "band-aid" in place.
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#360   Jeff Marincel

Jeff Marincel
  • Members
  • 5 posts

Posted 21 February 2012 - 16:15

OK, I took the band aid off.