Jump to content



Photo
- - - - -

[Contribution] Upgrading osC from 2.2 MS2 to 2.2 RC2a


  • Please log in to reply
111 replies to this topic

#101   Jaya

Jaya
  • Members
  • 8 posts
  • Real Name:Jaya

Posted 12 August 2010 - 20:37

Hi Jan,

Thanks for your contribution.

I'm in the process of upgrading a heavily modified site from 2.2 MS2 to 2.2 RC2a. Working on the test site I've modified all of the required files and everything seems to be fine until we reach checkout_shipping - we get a blank page. I've tried it with the original file in the add-on to replace the modified file in case it was one of the modifications causing the problem.

Was wondering if you could point me in the right direction as to where the problem may lie.

Cheers

#102   Jan Zonjee

Jan Zonjee

    Governor of Peace

  • Core Team
  • 7,094 posts
  • Real Name:Jan Zonjee
  • Gender:Male
  • Location:the Netherlands

Posted 12 August 2010 - 20:53

Was wondering if you could point me in the right direction as to where the problem may lie.

The error log. Since your hosting provider has switched off displaying errors (with good reason) there surely must be an error log.

#103   Jaya

Jaya
  • Members
  • 8 posts
  • Real Name:Jaya

Posted 12 August 2010 - 21:31

The error log. Since your hosting provider has switched off displaying errors (with good reason) there surely must be an error log.


Thanks Jan,

Found the error log, looks like includes/classes/order.php. Will look into it.

Regards,

jaya

#104   Proenski

Proenski
  • Members
  • 41 posts
  • Real Name:Proenski Kaproensky

Posted 09 November 2010 - 21:29

Hallo Jan,

I've used your contribution and it looks like things are working again however I can no longer login into the admin section of the shop. I've understood that the administrator table didn't excist in MS2 so I copied the table from a more recent (RC2) shop I have and imported it into the database but I still couldn't login.

So I emptied the users and passwords hoping I would get a request to setup a new admin account when trying to login. It didn't and now I'm stuck so any help is appreciated.

I do have some understanding of things (through practical experience) but I am by no means an expert... /huh.gif' class='bbc_emoticon' alt=':huh:' />

#105   esthera

esthera
  • Members
  • 24 posts
  • Real Name:Esther Albert

Posted 24 May 2011 - 18:42

Where do I find the sql changes for this upgrade?

#106   dom1959

dom1959
  • Members
  • 18 posts
  • Real Name:Dominique

Posted 04 June 2011 - 00:51

Hi,

Have just finished upgrading from 2.2MS2 to 2.2RC2a.
In addition I have changed webhost and name of domene for my store.
Both my store and my admin is totally blank, just a white screen, no error message.

Have tried for several days now, buth no luck in figuring this one out.

Right after changing host, I uploaded all old storefiles to my new webhotel and it worked, both catalog and admin showed on the internet.
Then I upgraded from MS2 to RC2a -> both store and admin totally blank
Then I went through all files to change all path directions to new pathdirections and also change the storename and domenename.

In my old store the path was like this: www.mydomain.com/catalog........ (right at the root)
In my new store the path has one extra folder: www.mydomain2.no/public_html/catalog......

I did not think that /public_html should be in the pathdirections in any other files than the configure files, but maybe I'm wrong?

Also I use an old sts free template. I have been told that I must upgrade this. I will start this work now, but could this be the reason that my store and admin now both are blank?


Any idea in which files I can start to look for the cause?
And what code?

Please help anyone :-)

Thanks :-)

Hi there,
I was wondering if you mind helping me out from upgrading from 2.2MS2 to 2.2 RC2a
I've been trying for day and no luck
I have got diffmerge but I don't know how to use it, and don't know where to start
Thanks in advance
Dominique

#107   esthera

esthera
  • Members
  • 24 posts
  • Real Name:Esther Albert

Posted 07 June 2011 - 07:38

I updated and i'm getting an error

1054 - Unknown column 'customers_name' in 'field list'

insert into orders_products (customers_id, customers_name, customers_company, customers_street_address, customers_suburb, customers_city, customers_postcode, customers_state, customers_country, customers_telephone, customers_email_address, customers_address_format_id, delivery_name, delivery_company, delivery_street_address, delivery_suburb, delivery_city, delivery_postcode, delivery_state, delivery_country, delivery_address_format_id, billing_name, billing_company, billing_street_address, billing_suburb, billing_city, billing_postcode, billing_state, billing_country, billing_address_format_id, payment_method, cc_type, cc_owner, cc_number, cc_expires, date_purchased, orders_status, currency, currency_value, ip_address) values ('711',



did the table syntax change that customer info is with ordered products or did I do something wrong>

#108   Remco Leuven

Remco Leuven
  • Members
  • 11 posts
  • Real Name:Remco Leuven

Posted 11 January 2012 - 15:11

Hi Jan, regarding my Ideal emailreminder issue from page 5, here I am again. The issue is still not fixed, after some time of not looking at it anymore I am working on this issue again.

My latest findings are that somehow a session is not ending correctly. Let me give you an example.

I ordered a product and paid via ideal. The ordernumber was 1413, no email confirmation
I made some changes as mentioned by you in the past, just to try them again
I made a new order via ideal, the ordernumber was 1414 and what happened> i receive two emailaconfirmations about order 1413, but the time between those orders was about 30 minutes, so it could never be the real confirmation of 1413, it was triggered then ordering order 1414. Strange or what.

I did find something interesting in the SQL database, but I don't know what caused this:
Attached File  ideal_issue.jpg   19.25KB   6 downloads

When starting the idealpayment for 1414, order 1413 is put in the database with same entrancecode.

Any thoughts?

Edited by Remco Leuven, 11 January 2012 - 15:12.


#109   Irin

Irin
  • Members
  • 801 posts
  • Real Name:Irina
  • Gender:Female
  • Location:Texas

Posted 27 April 2012 - 18:31

Hello,

I'm following upgrade instructions found in the document "Upgrading osC from 2.2 MS2 to 2.2 RC2a". My PHP Version 4.4.9, MySQL 4.1.22.

After the following change in step 19: admin/includes/functions/html_output.php, I'm getting blank pages in admin.

Line 273-274 (294-295 in changed file) [Add the Session ID to GET Based Forms]
**BEFORE**
//// // Output a form pull down menu
**ADD**
////
// Hide form elements
  function tep_hide_session_id() {
	$string = '';

	if (defined('SID') && tep_not_null(SID)) {
	  $string = tep_draw_hidden_field(tep_session_name(), tep_session_id());
	}

	return $string;
  }
I was wondering what can be the problem here.
Thanks for help.

#110   redrum

redrum
  • Members
  • 218 posts
  • Real Name:Fredrik
  • Gender:Male

Posted 26 May 2012 - 18:48

I have a custom made one-page-checkout (namned checkout.php). In the country pull down menu I used to have Sweden as pre-selected.
That pre-selection was disapeared after the upgrade to rc2a. This is due to the new function tep_draw_pull_down_menu in includes/functions/html_output.php

So if I use the rc2a:
  function tep_draw_pull_down_menu($name, $values, $default = '', $parameters = '', $required = false) {
	global $HTTP_GET_VARS, $HTTP_POST_VARS;
	$field = '<select name="' . tep_output_string($name) . '"';
	if (tep_not_null($parameters)) $field .= ' ' . $parameters;
	$field .= '>';
	if (empty($default) && ( (isset($HTTP_GET_VARS[$name]) && is_string($HTTP_GET_VARS[$name])) || (isset($HTTP_POST_VARS[$name]) && is_string($HTTP_POST_VARS[$name])) ) ) {
	  if (isset($HTTP_GET_VARS[$name]) && is_string($HTTP_GET_VARS[$name])) {
		$default = stripslashes($HTTP_GET_VARS[$name]);
	  } elseif (isset($HTTP_POST_VARS[$name]) && is_string($HTTP_POST_VARS[$name])) {
		$default = stripslashes($HTTP_POST_VARS[$name]);
	  }
	}
	for ($i=0, $n=sizeof($values); $i<$n; $i++) {
	  $field .= '<option value="' . tep_output_string($values[$i]['id']) . '"';
	  if ($default == $values[$i]['id']) {
		$field .= ' SELECTED';
	  }
	  $field .= '>' . tep_output_string($values[$i]['text'], array('"' => '&quot;', '\'' => '&#039;', '<' => '&lt;', '>' => '&gt;')) . '</option>';
	}
	$field .= '</select>';
	if ($required == true) $field .= TEXT_FIELD_REQUIRED;
	return $field;
  }
no country is pre-selected.

If I use the old ms2:
  function tep_draw_pull_down_menu($name, $values, $default = '', $parameters = '', $required = false) {
	$field = '<select name="' . tep_output_string($name) . '"';
	if (tep_not_null($parameters)) $field .= ' ' . $parameters;
	$field .= '>';
	if (empty($default) && isset($GLOBALS[$name])) $default = stripslashes($GLOBALS[$name]);
	for ($i=0, $n=sizeof($values); $i<$n; $i++) {
	  $field .= '<option value="' . tep_output_string($values[$i]['id']) . '"';
	  if ($default == $values[$i]['id']) {
		$field .= ' SELECTED';
	  }
	  $field .= '>' . tep_output_string($values[$i]['text'], array('"' => '&quot;', '\'' => '&#039;', '<' => '&lt;', '>' => '&gt;')) . '</option>';
	}
	$field .= '</select>';
	if ($required == true) $field .= TEXT_FIELD_REQUIRED;
	return $field;
  }
the store country is pre-selected just as it should.

This is how my code for selecting country looks like:
<?php echo tep_get_country_list('country', ($HTTP_POST_VARS['country'] ? $HTTP_POST_VARS['country'] : $order->billing['country']['id']),'onchange="sb=1;copy_shipping(document.getElementsByName(\'ship_as_bill\')[0],true);sb=0;getbillstatewithshipp();" class="checkoutCountry" style="width:145px;"') . '&nbsp;' . (tep_not_null(ENTRY_COUNTRY_TEXT) ? '<span class="inputRequirement">' . ENTRY_COUNTRY_TEXT . '</span>': ''); ?>

Should I stick to the old ms2 function tep_draw_pull_down_menu?
Or can anyone help me out modify the code for selecting country in my checkout.php?


Thanks,
Fredrik

#111   bbsemail

bbsemail
  • Members
  • 25 posts
  • Real Name:Brad
  • Gender:Male
  • Location:Los Angeles, CA

Posted 17 June 2012 - 04:50

I followed the instructions on upgrading from the contribution zip file I think from:
http://forums.oscomm...ms2-to-22-rc2a/

I ran all the queries and upgraded the database. All were successful.
In an attempt to get my site back up quickly I uploaded all the new files into both admin and the store.
I then made a quick edit of header.php and replaced the OSC banner with my site's
My site comes up http://www.hcca.org/ClubStore/
You can get to a category
If you try to bring up details on any item you get 1054 - Unknown column 'p.products_id' in 'on clause'.

I have traced this to the classes/PriceFormatter.php file but don't know how to fix it. Any help would be greatly appreciated.

Edited by bbsemail, 17 June 2012 - 05:03.


#112   Tezla

Tezla
  • Members
  • 5 posts
  • Real Name:Vince

Posted 03 September 2012 - 01:27

This is the support thread for the "Upgrading osC from 2.2 Milestone 2 to 2.2 RC2a" contribution (addon #6654).


Hello Jan,

I wanted to thank you for this Contribution. It worked fine for me.

http://forums.oscomm...php-5x-hosting/

Now, if I can just figure out how to re-integrate Ultra-Pics (or similar) . But that isn't a failing of this contrib. You stuff worked fine. Thanks again.