Jump to content



Photo
- - - - -

osCommerce 2.2-MS2 - is it safe to use? or is 2.2rca a must!


This topic has been archived. This means that you cannot reply to this topic.
1 reply to this topic

#1   techmob

techmob
  • Members
  • 15 posts

Posted 07 January 2009 - 18:30

Hi all, i am knew to oscommerce and i have noticed the latest version is oscommerce 2.2rca, i would use this version but i found the templates are difficult to do, so i have found a nice template to use but it is using the osCommerce 2.2-MS2 version.. i would happily use this aslong as it is safe?

when i run oscommerce 2.2-MS2 on my hosting i get a global register error which i don't with 2.2rca, so to get around this error i have currently put php_value register_globals "on" in the .htaccess file, but is that a security risk?

i read about a patch or something for this for the MS2 version would that be a safer way to do it?

is there such a need to run the latest oscommerce 2.2rca for security bugs ? is osCommerce 2.2-MS2 vulnerable to being hacked at all?

thanks for reading!

Edited by techmob, 07 January 2009 - 18:33.


#2   GemRock

GemRock
  • Members
  • 2,074 posts

Posted 07 January 2009 - 21:49

they are all safe in themselves but could be used in an unsafe way - its just like your car. cr2a is the latest release.
Ken
commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).
over 20 years of computer programming experience.