Jump to content



Worldpay redirecting to CANCELLED page


  • Please log in to reply
3 replies to this topic

#1   sapphal

sapphal
  • Members
  • 45 posts
  • Real Name:Howard

Posted 04 March 2008 - 11:08 AM

For some strange reason when the customer pays through worldpay the page redirects to payment cancelled and then to the checkout_payment.php page.  The payment goes through but the cart is not checked out and the order doesn't go into the database.  This has only happened recently and coincided with having to install the register globals contribution 2079.

How can I get it to go to the correct page?

Please help

Howard

#2   sapphal

sapphal
  • Members
  • 45 posts
  • Real Name:Howard

Posted 04 March 2008 - 11:24 AM

By the way I am using contribution http://addons.oscommerce.com/info/882 v1.4 for the worldpay processing.

Howard

#3   precise-minds

precise-minds
  • Members
  • 1 posts
  • Real Name:Matt Collins

Posted 07 March 2008 - 01:48 PM

View Postsapphal, on Mar 4 2008, 11:24 AM, said:

By the way I am using contribution http://addons.oscommerce.com/info/882 v1.4 for the worldpay processing.

Howard
I've been having the same problem with an installation for one of our clients. I've now fixed it but I can't understand how it broke.
Looking at the code, I couldn't find any where within any of the site code that the transaction status was being set.

In /shop/wpcallback.php on line 80, there is the following test

	  if(isset($transStatus) && $transStatus == "Y") {


This was always failing as $transStatus is empty

At the top of the page I have now included a line:
  $transStatus = $_REQUEST['transStatus'];

This picks up the value coming back from worldpay.


I am at a complete loss as to how this value was ever being set before hand.

#4   noncents

noncents
  • Members
  • 8 posts
  • Real Name:Ricky
  • Gender:Male
  • Location:Gosport, UK

Posted 10 June 2008 - 07:40 PM

View Postprecise-minds, on Mar 7 2008, 02:48 PM, said:

I've been having the same problem with an installation for one of our clients. I've now fixed it but I can't understand how it broke.
Looking at the code, I couldn't find any where within any of the site code that the transaction status was being set.

In /shop/wpcallback.php on line 80, there is the following test

	  if(isset($transStatus) && $transStatus == "Y") {


This was always failing as $transStatus is empty

At the top of the page I have now included a line:
  $transStatus = $_REQUEST['transStatus'];

This picks up the value coming back from worldpay.


I am at a complete loss as to how this value was ever being set before hand.

For all those of you beating your head against a brick wall because the WorldPay callback doesn't work try this. I tried everything and then I simply amended this bit of code and it came to life!! I noticed loads of people having this problem without any solution so seriously give this a go, it worked for me!
"If I have seen further it is by standing on the shoulders of giants"