Jump to content



Photo
- - - - -

Fatal Error: Register_globals Is Disabled In Php.ini, Please Enable It!


This topic has been archived. This means that you cannot reply to this topic.
12 replies to this topic

#1   ksarun

ksarun
  • Members
  • 3 posts

Posted 03 June 2007 - 10:50

FATAL ERROR: register_globals is disabled in php.ini, please enable it! CAN U HELP ME

#2   Andrew Yuen

Andrew Yuen
  • Members
  • 648 posts

Posted 03 June 2007 - 11:36

http://blogs.oscomme...s-on-the-forum/ Refer to #4
Andrew Yuen
osCommerce, Community Team

#3   ksarun

ksarun
  • Members
  • 3 posts

Posted 03 June 2007 - 15:17

http://blogs.oscomme...s-on-the-forum/ Refer to #4

Sir as per your reply i had applied it, but still i am getting same error ! Please help me?

#4   FaShUnPhOtOg

FaShUnPhOtOg
  • Members
  • 9 posts

Posted 03 June 2007 - 15:27

http://blogs.oscomme...s-on-the-forum/ Refer to #4

Yeah, I followed the instructions in the blog and uploaded a php.ini file (yes, I made sure it was .ini and NOT .ini.txt) to the catalog folder and I still get the fatal error message just like the person before me. Any further help would be appreciated.

F

#5   FaShUnPhOtOg

FaShUnPhOtOg
  • Members
  • 9 posts

Posted 03 June 2007 - 15:36

Yeah, I followed the instructions in the blog and uploaded a php.ini file (yes, I made sure it was .ini and NOT .ini.txt) to the catalog folder and I still get the fatal error message just like the person before me. Any further help would be appreciated.

F



Never mind, I found it... for those using PHP4 (not 3), go into your catalog folder and located the .htaccess file. Open that file in Edit mode and uncomment out (remove the # symbol) the line #php_value register_globals 1. While you're at it, you may want to uncomment out the line above it: php_value session.use_trans_sid 0 though I'm not sure what it does yet.

Uncommenting out the line about the register_globals gets me into the installation section. Now to see if I can get all the way through without any further problems! /smile.gif' class='bbc_emoticon' alt=':)' />

F

#6   satish

satish
  • Members
  • 5,350 posts

Posted 03 June 2007 - 16:24

four ways to get thru.
1)As You did in htaccess.
2)Can place a php.ini file and set register globals to on.
3)Apply VGER register global patch.
4)replace all HTTP_****_VARS with $_****



Satish
Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

Check My About US For who am I and what My company does.

#7   Dragen

Dragen
  • Members
  • 185 posts

Posted 03 June 2007 - 23:58

Or I'd suggest applying the register globals off contrib. Makes it much more secure

#8   JHouse

JHouse
  • Members
  • 101 posts

Posted 26 July 2007 - 23:59

http://blogs.oscomme...s-on-the-forum/ Refer to #4


Thank you, the link you provided helped big time.

Thanks again.
JHouse

#9   sty1129

sty1129
  • Members
  • 12 posts

Posted 06 August 2007 - 08:47

Never mind, I found it... for those using PHP4 (not 3), go into your catalog folder and located the .htaccess file. Open that file in Edit mode and uncomment out (remove the # symbol) the line #php_value register_globals 1. While you're at it, you may want to uncomment out the line above it: php_value session.use_trans_sid 0 though I'm not sure what it does yet.

Uncommenting out the line about the register_globals gets me into the installation section. Now to see if I can get all the way through without any further problems! /smile.gif' class='bbc_emoticon' alt=':)' />

F



Thanks a lot for this tips! It works for me, after i tried all other solutions!
Thanks again!

#10   digibiz08

digibiz08
  • Members
  • 11 posts

Posted 24 June 2008 - 12:41

Never mind, I found it... for those using PHP4 (not 3), go into your catalog folder and located the .htaccess file. Open that file in Edit mode and uncomment out (remove the # symbol) the line #php_value register_globals 1. While you're at it, you may want to uncomment out the line above it: php_value session.use_trans_sid 0 though I'm not sure what it does yet.

Uncommenting out the line about the register_globals gets me into the installation section. Now to see if I can get all the way through without any further problems! /smile.gif' class='bbc_emoticon' alt=':)' />

F


Hi, i followed your procedure, but doesnt work for me. The error were still there.
By the way, what is uncomment and how to do it?

#11   AUwebman

AUwebman
  • Members
  • 5 posts

Posted 11 July 2008 - 19:38

Hi, i followed your procedure, but doesnt work for me. The error were still there.
By the way, what is uncomment and how to do it?


What they mean by "uncomment" is deleting the "#" in front of php_value register_globals 1

Before:
# php_value register_globals 1
After:
php_value register_globals 1

A "comment" is something that appears in the code, but isn't read by the program that's using the code. So if something is commented then the program skips over it as if that line didn't exist. In this case they use the comment ability to turn off part of the coding. It's also used for denoting certain things for the programmers working on the code, like...

# this function turns the switch on or off, 1 for on, 0 for off
example_function_switch = 1


If the "#" were not in there in the first line, the program would try to read "this function turns the switch on or off, 1 for one, 0 for off" as if it were actual code, and it would mess up the program. The next line doesn't have the "#" in front of it so the program will read that as code, as it should.

And that's about all I know about programming lol. So delete that and see if it works.

#12   MrPhil

MrPhil
  • Members
  • 5,292 posts

Posted 12 July 2008 - 15:40

Note that in some systems, .htaccess does not always allow "php_value" entries. Those have to go into a "php.ini" file (with a different syntax). Some systems, furthermore, require an entry in .htaccess to tell the server where to find php.ini. You need to talk with your hosting service to see what's required.

#13   blairh

blairh
  • Members
  • 33 posts

Posted 29 December 2010 - 13:35

Never mind, I found it... for those using PHP4 (not 3), go into your catalog folder and located the .htaccess file. Open that file in Edit mode and uncomment out (remove the # symbol) the line #php_value register_globals 1. While you're at it, you may want to uncomment out the line above it: php_value session.use_trans_sid 0 though I'm not sure what it does yet.

Uncommenting out the line about the register_globals gets me into the installation section. Now to see if I can get all the way through without any further problems! /smile.gif' class='bbc_emoticon' alt=':)' />

F

legend.. worked like a CHARM!!!
now to install /biggrin.gif' class='bbc_emoticon' alt=':D' />