Jump to content



Photo
- - - - -

Initial setup


This topic has been archived. This means that you cannot reply to this topic.
9 replies to this topic

#1   ggseven

ggseven
  • Members
  • 4 posts

Posted 13 April 2007 - 23:24

I am a novice to all of this php/mysql so pls bear with me. I can't seem to initiate the install via the web browser. I did everything up until it says "Open your web browser and go to http://yourserver/catalog/install/ and click on theInstall button."...so in my browser I put in localhost/catalog/install and I get this error:

FATAL ERROR: register_globals is disabled in php.ini, please enable it!\

I proceeded to my php.ini coniguration file; changed the line register_globals = Off to equal 'ON'. Also played around with the line Session.bug_comat_42 and session.bug_comat_warn and switched the default of 1 to '0' and also tried '2'. One last thing I tried was the # php_value register_globals 1 line in the .htaccess file under the catalog folder.

No luck unfortunately. Any help is much appreciated.



Thanks in advance,

GG

#2   spax

spax
  • Members
  • 2,538 posts

Posted 14 April 2007 - 00:29

When you change the php.ini file, you need to re-start the server for the change to take effect.

#3   ggseven

ggseven
  • Members
  • 4 posts

Posted 14 April 2007 - 02:10

When you change the php.ini file, you need to re-start the server for the change to take effect.



Thanks for the quick response! yeah it makes sense what you said...I did that but unfortunately I still get that error msg. I'm using xampp 1.6.0a with php 5.2.1 running (not sure if any of that matters?) My php config file has global variables = on and that session.bug_compat-42 and warn lines equal to 1 (not sure if these two lines matter -- I tried equal to 0 also to no avail (am not totally sure which one is right))...Also, my xampp setup has a php.ini-recommended file and a php.ini-dist file (don't think these apply but I played around with them too)...

#4   nameiscorrie

nameiscorrie
  • Members
  • 241 posts

Posted 14 April 2007 - 02:20

Thanks for the quick response! yeah it makes sense what you said...I did that but unfortunately I still get that error msg. I'm using xampp 1.6.0a with php 5.2.1 running (not sure if any of that matters?) My php config file has global variables = on and that session.bug_compat-42 and warn lines equal to 1 (not sure if these two lines matter -- I tried equal to 0 also to no avail (am not totally sure which one is right))...Also, my xampp setup has a php.ini-recommended file and a php.ini-dist file (don't think these apply but I played around with them too)...


AFAIK, OSC does not run under php 5.+

#5   MagickWomyn

MagickWomyn
  • Members
  • 217 posts

Posted 14 April 2007 - 14:07

To switch to php 4 in Xampp:

Start.... run..... C:\Program Files\xampp\php-switch.bat
then enter 4
follow the prompt to exit
restart Xampp

HTH

#6   enigma1

enigma1
  • Members
  • 8,206 posts

Posted 14 April 2007 - 15:52

AFAIK, OSC does not run under php 5.+

It does. Because you should not do automatic installation on a live site. Better extract the archive and do it manually. And you can get around the php.ini restrictions like by using the register globals module

#7   spax

spax
  • Members
  • 2,538 posts

Posted 14 April 2007 - 19:14

AFAIK, OSC does not run under php 5.+


I use PHP5/MySql5 all the time locally, no problem.



Thanks for the quick response! yeah it makes sense what you said...I did that but unfortunately I still get that error msg. I'm using xampp 1.6.0a with php 5.2.1 running (not sure if any of that matters?) My php config file has global variables = on and that session.bug_compat-42 and warn lines equal to 1 (not sure if these two lines matter -- I tried equal to 0 also to no avail (am not totally sure which one is right))...Also, my xampp setup has a php.ini-recommended file and a php.ini-dist file (don't think these apply but I played around with them too)...


Did you change the correct php.ini file? There are 3! The one you want is in the xampp\apache\bin directory.

If you know what your live server environment is like, you could install the register globals mod as Mark suggests. It is unlikely you will be able to use the php.ini file on a shared server.

#8   rweis

rweis
  • Members
  • 1 posts

Posted 14 April 2007 - 22:30

I am a novice to all of this php/mysql so pls bear with me. I can't seem to initiate the install via the web browser. I did everything up until it says "Open your web browser and go to http://yourserver/catalog/install/ and click on theInstall button."...so in my browser I put in localhost/catalog/install and I get this error:

FATAL ERROR: register_globals is disabled in php.ini, please enable it!\

I proceeded to my php.ini coniguration file; changed the line register_globals = Off to equal 'ON'. Also played around with the line Session.bug_comat_42 and session.bug_comat_warn and switched the default of 1 to '0' and also tried '2'. One last thing I tried was the # php_value register_globals 1 line in the .htaccess file under the catalog folder.

No luck unfortunately. Any help is much appreciated.
Thanks in advance,

GG

Did you have any luck with this? I hit the same problem and after browsing the PHP documentation discovered that setting "php_value register_globals 1" in the .htaccess file will ONLY work IF Apache is configured to allow overrides, " When using PHP as an Apache module, you can also change the configuration settings using directives in Apache configuration files (e.g. httpd.conf) and .htaccess files. You will need "AllowOverride Options" or "AllowOverride All" privileges to do so." - see http://ca.php.net/ma...ion.changes.php

I'm working on my own server (SuSE Linux), so as an experiment, I added the following to /ec/apache2/default-server.conf

<Directory "/srv/www/htdocs/catalog>
AllowOverride All
</Directory>

and it worked! Not sure what will happen when it comes to using a shared server...

Cheers,

R

#9   ggseven

ggseven
  • Members
  • 4 posts

Posted 14 April 2007 - 23:32

AFAIK, OSC does not run under php 5.+



Thanks for the response. Well, this doesn't help me. I really want to checkout osCommerce but I guess I will wait a little bit (my xampp has a PHP switch functionality but I don't want to mess around with it at the moment)

Thanks again!

#10   ggseven

ggseven
  • Members
  • 4 posts

Posted 14 April 2007 - 23:38

I use PHP5/MySql5 all the time locally, no problem.
Did you change the correct php.ini file? There are 3! The one you want is in the xampp\apache\bin directory.

If you know what your live server environment is like, you could install the register globals mod as Mark suggests. It is unlikely you will be able to use the php.ini file on a shared server.



Problem resolved...that indeed was the correct php.ini (jeez why are there so many...). Much appreciated.Thanks so much!!!