Jump to content



- - - - -

Failed to open stream: Permission denied.


This topic has been archived. This means that you cannot reply to this topic.
13 replies to this topic

#1   buynotebookscheap

buynotebookscheap
  • Members
  • 91 posts

Posted 13 April 2007 - 09:49 PM

Warning: main(shop/includes/application_top.php) [function.main]: failed to open stream: Permission denied in /home/datpcst/public_html/index.php on line 13

Warning: main(shop/includes/application_top.php) [function.main]: failed to open stream: Permission denied in /home/datpcst/public_html/index.php on line 13

Warning: main(shop/includes/application_top.php) [function.main]: failed to open stream: Permission denied in /home/datpcst/public_html/index.php on line 13

Fatal error: main() [function.require]: Failed opening required 'shop/includes/application_top.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/datpcst/public_html/index.php on line 13
Buy Notebooks Cheap

#2   buynotebookscheap

buynotebookscheap
  • Members
  • 91 posts

Posted 13 April 2007 - 09:53 PM

View Postbuynotebookscheap, on Apr 13 2007, 02:49 PM, said:

Warning: main(shop/includes/application_top.php) [function.main]: failed to open stream: Permission denied in /home/datpcst/public_html/index.php on line 13

Warning: main(shop/includes/application_top.php) [function.main]: failed to open stream: Permission denied in /home/datpcst/public_html/index.php on line 13

Warning: main(shop/includes/application_top.php) [function.main]: failed to open stream: Permission denied in /home/datpcst/public_html/index.php on line 13

Fatal error: main() [function.require]: Failed opening required 'shop/includes/application_top.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/datpcst/public_html/index.php on line 13


Line 13:   require('shop/includes/application_top.php');
Buy Notebooks Cheap

#3   bkellum

bkellum
  • Members
  • 4,893 posts

Posted 13 April 2007 - 10:00 PM

View Postbuynotebookscheap, on Apr 13 2007, 04:53 PM, said:

Line 13: require('shop/includes/application_top.php');
Check your files to be sure they have permissions set at 644, except for the admin/includes/configure.php and includes/configure.php files, which should be set at 644.
Check that your folders have permissions set at 755.
Bill Kellum

Sounds Good Productions
STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

#4   buynotebookscheap

buynotebookscheap
  • Members
  • 91 posts

Posted 13 April 2007 - 10:09 PM

View Postbkellum, on Apr 13 2007, 03:00 PM, said:

Check your files to be sure they have permissions set at 644, except for the admin/includes/configure.php and includes/configure.php files, which should be set at 644.
Check that your folders have permissions set at 755.
Shop folder has 000 what is that?
Which file control this?
Buy Notebooks Cheap

#5   bkellum

bkellum
  • Members
  • 4,893 posts

Posted 13 April 2007 - 10:17 PM

View Postbuynotebookscheap, on Apr 13 2007, 05:09 PM, said:

Shop folder has 000 what is that?
Don, that is OK.

Quote

Which file control this?
If you are hosted on a Unix server, then you can easily change permissions using your FTP Client.
If you are on a Windows server, simply navigate to the file in windows, right click on it, select properties, and change the settings from there.
Bill Kellum

Sounds Good Productions
STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

#6   buynotebookscheap

buynotebookscheap
  • Members
  • 91 posts

Posted 13 April 2007 - 10:38 PM

View Postbkellum, on Apr 13 2007, 03:17 PM, said:

Don, that is OK.

If you are hosted on a Unix server, then you can easily change permissions using your FTP Client.
If you are on a Windows server, simply navigate to the file in windows, right click on it, select properties, and change the settings from there.
I am on UNIX, I tried through ftp permission denied.
Buy Notebooks Cheap

#7   buynotebookscheap

buynotebookscheap
  • Members
  • 91 posts

Posted 13 April 2007 - 10:50 PM

View Postbuynotebookscheap, on Apr 13 2007, 03:38 PM, said:

I am on UNIX, I tried through ftp permission denied.
Do the permissions change on there own?
Buy Notebooks Cheap

#8   lawandorder

lawandorder
  • Members
  • 55 posts

Posted 13 April 2007 - 11:46 PM

Hope you don't mind me jumping in here but I am having the same problem. I changed the permissions using ftp but since I left the configure files as they were when I was developing the site on my windows localhost I'm afraid the paths may be wrong. Do you know what I should change in the configure files to suit the web server.

#9   buynotebookscheap

buynotebookscheap
  • Members
  • 91 posts

Posted 14 April 2007 - 12:06 AM

View Postlawandorder, on Apr 13 2007, 04:46 PM, said:

Hope you don't mind me jumping in here but I am having the same problem. I changed the permissions using ftp but since I left the configure files as they were when I was developing the site on my windows localhost I'm afraid the paths may be wrong. Do you know what I should change in the configure files to suit the web server.
I am trying to change the permission on this folder access denied, are there other ways to edit the folder properties?
Buy Notebooks Cheap

#10   bkellum

bkellum
  • Members
  • 4,893 posts

Posted 14 April 2007 - 01:28 AM

View Postbuynotebookscheap, on Apr 13 2007, 05:50 PM, said:

Do the permissions change on there own?
No, they will not. However, depending upon the practises of your host, they may change them inadvertantly (not a good host).

By the way, what host do you use? I recently had to contact Network Solutions for a client since the host had changed the permissions and then the client could no longer change the permissions via FTP. You may have to do the same.
Bill Kellum

Sounds Good Productions
STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

#11   bkellum

bkellum
  • Members
  • 4,893 posts

Posted 14 April 2007 - 01:41 AM

View Postlawandorder, on Apr 13 2007, 06:46 PM, said:

Hope you don't mind me jumping in here but I am having the same problem. I changed the permissions using ftp but since I left the configure files as they were when I was developing the site on my windows localhost I'm afraid the paths may be wrong. Do you know what I should change in the configure files to suit the web server.
Brian, you will need to check the server and database paths in both the admin/includes/configure.php and includes/configure.php files.

Here is a good guide to help you out with this:

http://forums.oscommerce.com/index.php?showtopic=193738
Bill Kellum

Sounds Good Productions
STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

#12   buynotebookscheap

buynotebookscheap
  • Members
  • 91 posts

Posted 14 April 2007 - 02:25 AM

View Postbkellum, on Apr 13 2007, 06:41 PM, said:

Brian, you will need to check the server and database paths in both the admin/includes/configure.php and includes/configure.php files.

Here is a good guide to help you out with this:

http://forums.oscommerce.com/index.php?showtopic=193738
I was able to change the permissions inside cpanel >>File Manager>>Folder>>change permission and we are all good for now.
Buy Notebooks Cheap

#13   bbg

bbg
  • Members
  • 1 posts

Posted 16 April 2007 - 03:44 AM

View Postbkellum, on Apr 13 2007, 02:00 PM, said:

Check your files to be sure they have permissions set at 644, except for the admin/includes/configure.php and includes/configure.php files, which should be set at 644.
Check that your folders have permissions set at 755.

How do you change the permission of a file? I am having the same problem.

Thanks,

bbg

#14   bkellum

bkellum
  • Members
  • 4,893 posts

Posted 16 April 2007 - 04:09 AM

View Postbbg, on Apr 15 2007, 10:44 PM, said:

How do you change the permission of a file? I am having the same problem.

Thanks,

bbg
Most will use a FTP client software program such as SmartFTP to change the permissions and it usually works like this:

Open your store files in a FTP client software. Once you can visually view the folders and file names, you should be able to right click on any particular folder/file and select CHMOD/Properties.
Depending upon the FTP client software that you are using, it should display some options to allow you to enter a number such as 644, 755, 777, etc.

Enter the correct permission settings and away you go.

Note: You will need to know what type of server your host is using since it will have direct implications upon how you will be able to change file/folder permissions. Hopefully you are hosted on a Unix server which allows you to change permissions as described above.

Hope this has helped you out,
Bill Kellum

Sounds Good Productions
STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE