Jump to content



- - - - -

failed to open stream: No such file or directory


  • Please log in to reply
11 replies to this topic

#1   Skyler

Skyler
  • Members
  • 2 posts
  • Real Name:Skyler

Posted 26 December 2006 - 05:46 PM

I have OSC version oscommerce-2.2ms2-060817 installe with languagepack Dutch (NL_Taalpakket_v1.4.9_1_2)
I can use the Admninistration Tool without trouble (and in Dutch).

When i want to start the Catalog i get the error's:

Warning: main(includes/languages/Dutch.php) [function.main]: failed to open stream: No such file or directory in (path)  ../catalog/includes/application_top.php on line 285

Warning: main(includes/languages/Dutch.php) [function.main]: failed to open stream: No such file or directory in (path)  ../catalog/includes/application_top.php on line 285

Fatal error: main() [function.require]: Failed opening required 'includes/languages/Dutch.php' (include_path='.:/usr/local/lib/php') in (path) ../catalog/includes/application_top.php on line 285

I already renamed the file in the named path to Dutch.php instead of dutch.php but i get the same result

Can anyone tell me what im doing wrong?

#2   crash3903

crash3903
  • Members
  • 1,822 posts
  • Real Name:Mark Reynolds
  • Location:United Kingdom

Posted 26 December 2006 - 05:49 PM

check to see if you have this file in your store root directory

includes/languages/Dutch.php

if it is there check if the first letter is upper case or lower case
Regards

Mark A Reynolds

#3   Skyler

Skyler
  • Members
  • 2 posts
  • Real Name:Skyler

Posted 27 December 2006 - 12:45 AM

View Postcrash3903, on Dec 26 2006, 06:49 PM, said:

check to see if you have this file in your store root directory

includes/languages/Dutch.php

if it is there check if the first letter is upper case or lower case



tnx 4 the reply

The file is there and already renamed it (see last line in original message)

Anyone more or other idea's?

#4   etronity

etronity
  • Members
  • 1 posts
  • Real Name:Matt

Posted 16 January 2007 - 08:43 PM

Check to see if you host has allowed fopen in your php.ini config file. Ask them to add the line:

allow_url_fopen = On

Hope it works for you.

#5   Mina X

Mina X
  • Members
  • 1 posts
  • Real Name:Mina

Posted 22 January 2007 - 11:42 PM

I had the exact same problem with language installation, and it`s also the same osCommerce version. I checked the php.ini file and the setting is `allow url fopen = On`, so I guess that`s not a problem. Can anyone, please, tell me how you fixed it?

#6   newmanxtc

newmanxtc
  • Members
  • 3 posts
  • Real Name:Ro Mac

Posted 20 February 2007 - 02:50 AM

I am baffled and know that someone has the answer to this issue:

I get the following:


Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /home/content/b/t/s/btsGB07/html/catalog/includes/application_top.php on line 285

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /home/content/b/t/s/btsGB07/html/catalog/includes/application_top.php on line 285

Fatal error: main(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/local/lib/php') in /home/content/b/t/s/btsGB07/html/catalog/includes/application_top.php on line 285



[I suspect that my client 'disabled' the (all) language in the admin.   I set english back up but it didn't change anything]

Any help would be... well helpful.

Thanks

#7   viorelb

viorelb
  • Members
  • 4 posts
  • Real Name:buhoi viorel

Posted 10 December 2007 - 08:27 PM

i have the same problem with my site when i install oscommerce....
i find the problem in php.ini
i edited the file and it is disponible at www.mongelluzzihoreca.com/php.ini
good luck

#8   adam@ibexuk.com

adam@ibexuk.com
  • Members
  • 16 posts
  • Real Name:Adam

Posted 23 October 2008 - 09:11 PM

I've just come up against the same problem moving my previously working OS Commerce V2.2 MS2 site to a new server with PHP5.

Turned out that I needed to turn register_globals on in the php.ini file.

Having applied all of the changes to V2.2 MS2 I could find as part of my server move work (Updates 051112, 051113 & 060817) I'd been hoping that the need to turn on register_globals was no more, but can anyone tell me if this is still a normal requirement for os commerce?

Edited by adam@ibexuk.com, 23 October 2008 - 09:15 PM.


#9   adam@ibexuk.com

adam@ibexuk.com
  • Members
  • 16 posts
  • Real Name:Adam

Posted 23 October 2008 - 10:02 PM

View Postadam@ibexuk.com, on Oct 23 2008, 10:11 PM, said:

I've just come up against the same problem moving my previously working OS Commerce V2.2 MS2 site to a new server with PHP5.

Turned out that I needed to turn register_globals on in the php.ini file.

Having applied all of the changes to V2.2 MS2 I could find as part of my server move work (Updates 051112, 051113 & 060817) I'd been hoping that the need to turn on register_globals was no more, but can anyone tell me if this is still a normal requirement for os commerce?

Please ignore my question about the need to turn on register_globals.  I've now seen that I can acheive this is if I upgrade my site to V2.2 RC1.

#10   imajio

imajio
  • Members
  • 7 posts
  • Real Name:Dre
  • Gender:Male

Posted 02 July 2010 - 02:58 AM

View Postnewmanxtc, on 20 February 2007 - 02:50 AM, said:

I am baffled and know that someone has the answer to this issue:

I get the following:


Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /home/content/b/t/s/btsGB07/html/catalog/includes/application_top.php on line 285

Warning: main(includes/languages/.php): failed to open stream: No such file or directory in /home/content/b/t/s/btsGB07/html/catalog/includes/application_top.php on line 285

Fatal error: main(): Failed opening required 'includes/languages/.php' (include_path='.:/usr/local/lib/php') in /home/content/b/t/s/btsGB07/html/catalog/includes/application_top.php on line 285



[I suspect that my client 'disabled' the (all) language in the admin.   I set english back up but it didn't change anything]

Any help would be... well helpful.

Thanks

Were you able to get this issue resolved?

#11   imajio

imajio
  • Members
  • 7 posts
  • Real Name:Dre
  • Gender:Male

Posted 02 July 2010 - 03:52 AM

View Postviorelb, on 10 December 2007 - 08:27 PM, said:

i have the same problem with my site when i install oscommerce....
i find the problem in php.ini
i edited the file and it is disponible at www.mongelluzzihoreca.com/php.ini
good luck

I am not able to access that php.ini file that you have... are you able to make is accessible please?

#12   yadwinder

yadwinder
  • Members
  • 3 posts
  • Real Name:yaadwinder dhillon

Posted 10 April 2011 - 12:32 PM

hello friends

I am getting this error in my website all the time when I try to upload any theme.

Warning: require(/home/ytubeclu/public_html/wp-content/themes/magiting-blue/functions/option.php) [function.require]: failed to open stream: No such file or directory in /home/ytubeclu/public_html/wp-content/themes/magiting-blue/magiting-blue/functions.php on line 18

Fatal error: require() [function.require]: Failed opening required '/home/ytubeclu/public_html/wp-content/themes/magiting-blue/functions/option.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/ytubeclu/public_html/wp-content/themes/magiting-blue/magiting-blue/functions.php on line 18

Please help me friends
thanks in advance.