Jump to content



Photo
- - - - -

Admin htaccess


This topic has been archived. This means that you cannot reply to this topic.
8 replies to this topic

#1   guiness

guiness
  • Members
  • 36 posts

Posted 17 September 2002 - 20:34

OK, I've been on this for two hours and have gone through the million pages in the forum on it. So what am I doing wrong? I'm set up local on winxp pro, running latest apache/php versions with OSC 2.2-

inside my admin folder-
htaccess:
AuthUserFile /apache/htdocs/.htpasswd
AuthName Admin
AuthType Basic
<Limit GET POST>
require user king
</Limit>

outside my admin folder-
htpasswd:
king:guf0jyb38NlK

I'm not presented with an access box... just goes straight to page. Any ideas?

#2   hobbzilla

hobbzilla
  • Members
  • 827 posts

Posted 17 September 2002 - 20:57

I'm set up local on winxp pro...
AuthUserFile /apache/htdocs/.htpasswd  


Wow! XP sure must have changes since Win2k. I still have to use directory letters (ie. C:/program files/apache group/apache2/htdocs/.htpasswd) to access my files.. I would much rather use the unix style though.. I guess I'll have to upgrade! :wink:

Try something like this:
=========================
AuthUserFile c:/Passwords/.htpasswd
AuthName "Localhost's Administration"
AuthType Basic
<Limit GET POST>
require valid-user
</Limit>
=========================

**NOTE** Storing your .htpasswd in htdocs is obsolutely CARELESS. Think about it.

#3   guiness

guiness
  • Members
  • 36 posts

Posted 17 September 2002 - 21:00

I'll give it a try. Thanks

Yah, my password file will not reside in the web area when it's uploaded. I figure I need to get it working first.... /biggrin.gif' class='bbc_emoticon' alt=':D' />

#4   guiness

guiness
  • Members
  • 36 posts

Posted 17 September 2002 - 21:07

OK, set up "passwords" folder and made changes to .htaccess.

Still opens page without requesting user/pass. My Apache install is all default, is there something there I need to be looking at?

#5   hobbzilla

hobbzilla
  • Members
  • 827 posts

Posted 17 September 2002 - 21:08

Make sure in httpd.conf you set:

AllowOverride All

#6   hobbzilla

hobbzilla
  • Members
  • 827 posts

Posted 17 September 2002 - 21:09

Don't forget to RESTART Apache after editing httpd.conf. You must do this upon any changes to httpd.conf , php.ini , showering, etc.

#7   guiness

guiness
  • Members
  • 36 posts

Posted 17 September 2002 - 21:15

OK, maybe this is it. Am I at the right place?

<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>


it should read?
<Directory />
Options FollowSymLinks
AllowOverride ALL
</Directory>

#8   guiness

guiness
  • Members
  • 36 posts

Posted 17 September 2002 - 21:16

actually I'm finding more instances of "allow overide none"....

#9   guiness

guiness
  • Members
  • 36 posts

Posted 17 September 2002 - 21:24

OK, got it.

The allowoveride none was a stand alone line. Changed it to ALL and all is good. Thanks! I must have tried every single possible combination of peoples ideas on this one.