Jump to content



Photo
- - - - -

Warning: set_time_limit() has been disabled for security reasons


This topic has been archived. This means that you cannot reply to this topic.
1 reply to this topic

#1   jamie06

jamie06
  • Members
  • 6 posts

Posted 05 July 2006 - 18:56

When deleting the basic categories from the vanilla OSC install I get the following message. It does complete the delete and I can press back and continue using the admin tool but I would like to stop it happening.

I have checked the full server path and it is correct.



Warning: set_time_limit() has been disabled for security reasons in /home/fhlinux186/s/**edited***/user/htdocs/catalog/admin/includes/functions/general.php on line 737

Warning: Cannot modify header information - headers already sent by (output started at /home/fhlinux186/s/**edited***/user/htdocs/catalog/admin/includes/functions/general.php:737) in /home/fhlinux186/s/**edited***/user/htdocs/catalog/admin/includes/functions/general.php on line 22


Any help would be well recieved!
Jamie

#2   choosealogin

choosealogin
  • Members
  • 1,108 posts

Posted 05 July 2006 - 19:18

Your host has set_time_limit disabled

It's called for in categories.php, backup.php, and newsletters.php ...probably a few more too, wherever a lengthy process might take place.

More info on set_time_limit is here and there are a lot of past threads about the error here

I'm not sure of the ultimate fix, although it's probably unlikely that your host will change that. Maybe a better answer lies in those other posts /huh.gif' class='bbc_emoticon' alt=':huh:' /> Hope it helps.

Edited by choosealogin, 05 July 2006 - 19:19.