Jump to content



Photo
- - - - -

Godaddy.com PHP.INI Register_Globals


This topic has been archived. This means that you cannot reply to this topic.
1 reply to this topic

#1   glock_22

glock_22
  • Members
  • 5 posts

Posted 22 June 2006 - 19:02

I am creating this topic to explain how I fixed the PHP.INI Register_Globals issue with Godaddy.com. You also need to understand that I am using shared server hosting.

I will explain the error message received.

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.


When I modified the .htaccess per some of the suggestions, I would get a 500 server error and nothing would load. (It didn't like the .htaccess fix) I through I tried everything and was about to change web hosts.

I went to the Godaddy website and read that they allow you to modify your own php.ini file. This file lives in your root website. This is "yourwebsite" and not "yourwebsite/catalog" Find the php.ini file and add (or change) the following line.

It should read

register_globals = on


Save this in your php.ini file and leave it in your root directory.

It was an instant fix for me and I hope it clarifies problems for others.

#2   tkwin1104

tkwin1104
  • Members
  • 2 posts

Posted 02 January 2009 - 06:39

Ok I figured it out. You have to add php5.ini if you have a godaddy account. You must add this file in three places - catolog, admin, install. Make sure it, reads register_globals = ON ,because you are changing your settings on godaddys server not on the website.
I am running php5 on a shared hosting plan with Mysql 4.1