Jump to content



Photo
- - - - -

Super Contact us enhancement 1.0


  • Please log in to reply
339 replies to this topic

#61   fcting

fcting
  • Members
  • 2 posts
  • Real Name:fcting
  • Gender:Female

Posted 14 March 2006 - 00:07

Hi,

I have problem with the contact us "visual verify code", my contact us page was working properly before switching to a new server. After migrating to new server the code image doesn't show anymore,

you can have a look at http://myevita.com/contact_us.php

is it something about PHP need to be installed?? Does anyone of you knows the problem? Thank you.

#62   Jeep_ice

Jeep_ice
  • Members
  • 150 posts
  • Real Name:Jean-Pierre

Posted 14 March 2006 - 14:41

Hi,

I have problem with the contact us "visual verify code", my contact us page was working properly before switching to a new server. After migrating to new server the code image doesn't show anymore,

you can have a look at http://myevita.com/contact_us.php

is it something about PHP need to be installed?? Does anyone of you knows the problem? Thank you.


I just checked and your problem is solved I think /rolleyes.gif' class='bbc_emoticon' alt=':rolleyes:' /> , the problem was i think, it's your hosting have not enabling the GD Library but now it's ok. nice site web by the way.
JEEP
--------------------
Installed Contributions:
osCommerce 2.2 Milestone MS2 + "Super Contact US Enhancement 1.1" + "Simple Template System (STS) 1.9" + "SPPC v.4.1.1" + "Column Product Listing for SPPC v4.1 v1.0" + "Quantity Price Breaks for SPPC 4.1.1"+ "Hide Price if $0 for "Quantity Price Breaks for SPPC 4.1.1" + "Show Price list for SPPC 4.1 v1.0"+ "EasyPopulate 2.72" + "Admin Reports Count Reset" + "Control Login 2.1" + "Credit card infobox" + "Customer Export" + "Customers Email and Phone in Order" + "Email for new customer 1.0" + "Handling fee" + "Phone Payment Credit Card Module 1.5" + "Purchase Orders version 1.3" + "Admin Comments Toolbar 4.0" + "Country-State Selector" + "Cart in Header for STS" + "Category Box Enhancement" + "Docs in Admin 1.0" + "Monthly Sales Report" + "Who's Online Enhancement" + "Whos Online 2.0" + "Simple Admin Access Control 1.2" and "Login box v2.2a" - Ouffffff !!! [img]http://forums.oscommerce.com/style_emoticons/default/smile.gif[/img]

#63   fcting

fcting
  • Members
  • 2 posts
  • Real Name:fcting
  • Gender:Female

Posted 14 March 2006 - 16:51

I just checked and your problem is solved I think :rolleyes: , the problem was i think, it's your hosting have not enabling the GD Library but now it's ok. nice site web by the way.



Yea, I think the admin installed that now. Thank you.

Do you help people doing contribution upgrade/installation? How much do you charge for that?

#64   chuckh2d

chuckh2d
  • Members
  • 57 posts
  • Real Name:Chuck Warner

Posted 15 March 2006 - 07:16

I don't know how much of the current VVC patch is shared in Super Contact Us, but it looks as though people on your thread have been having similar problems with messages not being sent.

The current version 2.1 of VVC is missing an essential file in includes/languages/english/images/buttons/ called button_submit.gif (other languages don't have it --or an equivalent-- either)

I've posted a usable button_submit.gif at the contribution page and hopefully it will become part of vvc2.2 rather soon.

#65   Jeep_ice

Jeep_ice
  • Members
  • 150 posts
  • Real Name:Jean-Pierre

Posted 15 March 2006 - 17:42

I don't know how much of the current VVC patch is shared in Super Contact Us, but it looks as though people on your thread have been having similar problems with messages not being sent.

The current version 2.1 of VVC is missing an essential file in includes/languages/english/images/buttons/ called button_submit.gif (other languages don't have it --or an equivalent-- either)

I've posted a usable button_submit.gif at the contribution page and hopefully it will become part of vvc2.2 rather soon.


Hi,

You're right about this and I knew that, but a lot of person have it's own button, so your button don't match with their button. I will try to do a button universel include in my future release of Super Contact us enhancement 2.0

By the way, just a question. have you try Super Contact us enhancement ? If not, install it and you will see what the problem is when you incorporate VCC in it. All is working except if you don't put the security code, it's send the email with no error.

I have to modify the code from VCC to be full compatible with Super Contact us enhancement. Install it and check that, you will understand.
JEEP
--------------------
Installed Contributions:
osCommerce 2.2 Milestone MS2 + "Super Contact US Enhancement 1.1" + "Simple Template System (STS) 1.9" + "SPPC v.4.1.1" + "Column Product Listing for SPPC v4.1 v1.0" + "Quantity Price Breaks for SPPC 4.1.1"+ "Hide Price if $0 for "Quantity Price Breaks for SPPC 4.1.1" + "Show Price list for SPPC 4.1 v1.0"+ "EasyPopulate 2.72" + "Admin Reports Count Reset" + "Control Login 2.1" + "Credit card infobox" + "Customer Export" + "Customers Email and Phone in Order" + "Email for new customer 1.0" + "Handling fee" + "Phone Payment Credit Card Module 1.5" + "Purchase Orders version 1.3" + "Admin Comments Toolbar 4.0" + "Country-State Selector" + "Cart in Header for STS" + "Category Box Enhancement" + "Docs in Admin 1.0" + "Monthly Sales Report" + "Who's Online Enhancement" + "Whos Online 2.0" + "Simple Admin Access Control 1.2" and "Login box v2.2a" - Ouffffff !!! [img]http://forums.oscommerce.com/style_emoticons/default/smile.gif[/img]

#66   Jeep_ice

Jeep_ice
  • Members
  • 150 posts
  • Real Name:Jean-Pierre

Posted 15 March 2006 - 17:44

Yea, I think the admin installed that now. Thank you.

Do you help people doing contribution upgrade/installation? How much do you charge for that?


Yes, of course.
JEEP
--------------------
Installed Contributions:
osCommerce 2.2 Milestone MS2 + "Super Contact US Enhancement 1.1" + "Simple Template System (STS) 1.9" + "SPPC v.4.1.1" + "Column Product Listing for SPPC v4.1 v1.0" + "Quantity Price Breaks for SPPC 4.1.1"+ "Hide Price if $0 for "Quantity Price Breaks for SPPC 4.1.1" + "Show Price list for SPPC 4.1 v1.0"+ "EasyPopulate 2.72" + "Admin Reports Count Reset" + "Control Login 2.1" + "Credit card infobox" + "Customer Export" + "Customers Email and Phone in Order" + "Email for new customer 1.0" + "Handling fee" + "Phone Payment Credit Card Module 1.5" + "Purchase Orders version 1.3" + "Admin Comments Toolbar 4.0" + "Country-State Selector" + "Cart in Header for STS" + "Category Box Enhancement" + "Docs in Admin 1.0" + "Monthly Sales Report" + "Who's Online Enhancement" + "Whos Online 2.0" + "Simple Admin Access Control 1.2" and "Login box v2.2a" - Ouffffff !!! [img]http://forums.oscommerce.com/style_emoticons/default/smile.gif[/img]

#67   jetski

jetski
  • Members
  • 19 posts
  • Real Name:Rodney Barrett
  • Gender:Male

Posted 19 March 2006 - 18:17

Super Contact US Enhancement 1.1 Will not deliver my email, after submitting the form it gives me this message "Your enquiry has been successfully sent to the Store Owner." but never get the email. I have installed this contrib and all looks good but no emails, I run test emails and get none. Just wondering if someone has the resolution to this problem and if so what you they did to solve this problem. Thanks....

#68   jetski

jetski
  • Members
  • 19 posts
  • Real Name:Rodney Barrett
  • Gender:Male

Posted 20 March 2006 - 13:16

Super Contact US Enhancement 1.1 Will not deliver my email, after submitting the form it gives me this message "Your enquiry has been successfully sent to the Store Owner." but never get the email. I have installed this contrib and all looks good but no emails, I run test emails and get none. Just wondering if someone has the resolution to this problem and if so what you they did to solve this problem. Thanks....







Problem Resolved: Found the problem in my php.ini file under the root directory.
This is the line I had to change:
[mail function]
; For Win32 only.
SMTP = localhost

; For Win32 only.
sendmail_from = admin@localhost

Changed to this:
[mail function]
; For Win32 only.
SMTP = localhost

; For Win32 only.
sendmail_from = your@yourdomain.com

#69   maz

maz
  • Members
  • 161 posts
  • Real Name:mazhar

Posted 20 March 2006 - 13:46

Hi

I need to add more fields on the contact us page and turn it into an application form which is emailed back to me. (cant find any forms contributions).

The problem I have is HOW to get the information to show in the BODY of the email?

At the moment the reason for 'enquiry' is showing only in the 'subject' heading part of my emails.
I need it to be displayed in the body with the rest of the message.

question ... answer
question ... answer
question ...answer


ANy help would be appreciated

Thanks

Maz

#70   Jeep_ice

Jeep_ice
  • Members
  • 150 posts
  • Real Name:Jean-Pierre

Posted 20 March 2006 - 15:02

Hi

I need to add more fields on the contact us page and turn it into an application form which is emailed back to me. (cant find any forms contributions).

The problem I have is HOW to get the information to show in the BODY of the email?

At the moment the reason for 'enquiry' is showing only in the 'subject' heading part of my emails.
I need it to be displayed in the body with the rest of the message.

question ... answer
question ... answer
question ...answer
ANy help would be appreciated

Thanks

Maz


Hi,

It's not the goal of this contribution. You want a form so it's another thing, it's have to be programmed for this. I don't have time to d this. Sorry.
JEEP
--------------------
Installed Contributions:
osCommerce 2.2 Milestone MS2 + "Super Contact US Enhancement 1.1" + "Simple Template System (STS) 1.9" + "SPPC v.4.1.1" + "Column Product Listing for SPPC v4.1 v1.0" + "Quantity Price Breaks for SPPC 4.1.1"+ "Hide Price if $0 for "Quantity Price Breaks for SPPC 4.1.1" + "Show Price list for SPPC 4.1 v1.0"+ "EasyPopulate 2.72" + "Admin Reports Count Reset" + "Control Login 2.1" + "Credit card infobox" + "Customer Export" + "Customers Email and Phone in Order" + "Email for new customer 1.0" + "Handling fee" + "Phone Payment Credit Card Module 1.5" + "Purchase Orders version 1.3" + "Admin Comments Toolbar 4.0" + "Country-State Selector" + "Cart in Header for STS" + "Category Box Enhancement" + "Docs in Admin 1.0" + "Monthly Sales Report" + "Who's Online Enhancement" + "Whos Online 2.0" + "Simple Admin Access Control 1.2" and "Login box v2.2a" - Ouffffff !!! [img]http://forums.oscommerce.com/style_emoticons/default/smile.gif[/img]

#71   Jeep_ice

Jeep_ice
  • Members
  • 150 posts
  • Real Name:Jean-Pierre

Posted 20 March 2006 - 15:06

Problem Resolved: Found the problem in my php.ini file under the root directory.
This is the line I had to change:
[mail function]
; For Win32 only.
SMTP = localhost

; For Win32 only.
sendmail_from = admin@localhost

Changed to this:
[mail function]
; For Win32 only.
SMTP = localhost

; For Win32 only.
sendmail_from = your@yourdomain.com


Hi,

Sorry to arrive too late for helping you, I'm happy that you have solved your problem.
JEEP
--------------------
Installed Contributions:
osCommerce 2.2 Milestone MS2 + "Super Contact US Enhancement 1.1" + "Simple Template System (STS) 1.9" + "SPPC v.4.1.1" + "Column Product Listing for SPPC v4.1 v1.0" + "Quantity Price Breaks for SPPC 4.1.1"+ "Hide Price if $0 for "Quantity Price Breaks for SPPC 4.1.1" + "Show Price list for SPPC 4.1 v1.0"+ "EasyPopulate 2.72" + "Admin Reports Count Reset" + "Control Login 2.1" + "Credit card infobox" + "Customer Export" + "Customers Email and Phone in Order" + "Email for new customer 1.0" + "Handling fee" + "Phone Payment Credit Card Module 1.5" + "Purchase Orders version 1.3" + "Admin Comments Toolbar 4.0" + "Country-State Selector" + "Cart in Header for STS" + "Category Box Enhancement" + "Docs in Admin 1.0" + "Monthly Sales Report" + "Who's Online Enhancement" + "Whos Online 2.0" + "Simple Admin Access Control 1.2" and "Login box v2.2a" - Ouffffff !!! [img]http://forums.oscommerce.com/style_emoticons/default/smile.gif[/img]

#72   iPAL

iPAL
  • Members
  • 3 posts
  • Real Name:Paul

Posted 29 March 2006 - 01:16

Great contib Jeep. Gives a great profesional look. My install went fine even with several other contribs. Only problem I'm haviving is the store fonts (minds much smaller and drabby looking) and how to change the store hours and drop down questions. Probably simple but I over looked it. Nothing new showed up in admin except 4 "contact us" email names. So how do I change the rest and make it look like your contrib?

#73   swtummers

swtummers
  • Members
  • 9 posts
  • Real Name:Sven W. Tummers

Posted 05 April 2006 - 02:10

Hi JEEP, I really believe that this is a great contrib, I can't get it to show up though. I posted my contact_us.tpl.php file. Could you please let me know what I should change? I tried multiple things, but I am still learning PHP.

Thanks a lot in advance!

<?php echo tep_draw_form('contact_us', tep_href_link(FILENAME_CONTACT_US, 'action=send')); ?><table border="0" width="100%" cellspacing="0" cellpadding="<?php echo CELLPADDING_SUB; ?>">
<?php
// BOF: Lango Added for template MOD
if (SHOW_HEADING_TITLE_ORIGINAL == 'yes') {
$header_text = ' '
//EOF: Lango Added for template MOD
?>
	  <tr>
		<td><table border="0" width="100%" cellspacing="0" cellpadding="0">
		  <tr>
			<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>
			<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . 'table_background_contact_us.gif', HEADING_TITLE, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>
		  </tr>
		</table></td>
	  </tr>
	  <tr>
		<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>
<?php
// BOF: Lango Added for template MOD
}else{
$header_text = HEADING_TITLE;
}
// EOF: Lango Added for template MOD
?>

<?php
// BOF: Lango Added for template MOD
if (MAIN_TABLE_BORDER == 'yes'){
table_image_border_top(false, false, $header_text);
}
// EOF: Lango Added for template MOD
?>
<?php
  if ($messageStack->size('contact') > 0) {
?>
	  <tr>
		<td><?php echo $messageStack->output('contact'); ?></td>
	  </tr>
	  <tr>
		<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>
<?php
  }

  if (isset($HTTP_GET_VARS['action']) && ($HTTP_GET_VARS['action'] == 'success')) {
?>
	   <tr>
		<td class="main" align="center"><?php echo tep_image(DIR_WS_IMAGES . 'table_background_man_on_board.gif', HEADING_TITLE, '0', '0', 'align="left"') . TEXT_SUCCESS; ?></td>
	  </tr>
	  <tr>
		<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>
<?php
// BOF: Lango Added for template MOD
if (MAIN_TABLE_BORDER == 'yes'){
table_image_border_bottom();
}
// EOF: Lango Added for template MOD
?>
	  <tr>
		<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>
	  <tr>
		<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
		  <tr class="infoBoxContents">
			<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
			  <tr>
				<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
				<td align="right"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_template_image_button('button_continue.gif', IMAGE_BUTTON_CONTINUE) . '</a>'; ?></td>
				<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
			  </tr>
			</table></td>
		  </tr>
		</table></td>
	  </tr>

<?php
  } else {
?>
	  <tr>
		<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
		  <tr class="infoBoxContents">
			<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
			  <tr>
				<td class="main"><?php echo ENTRY_NAME; ?></td>
			  </tr>
			  <tr>
				<td class="main"><?php echo tep_draw_input_field('name'); ?></td>
			  </tr>
			  <tr>
				<td class="main"><?php echo ENTRY_EMAIL; ?></td>
			  </tr>
			  <tr>
				<td class="main"><?php echo tep_draw_input_field('email'); ?></td>
			  </tr>
			  <tr>
				<td class="main"><?php echo ENTRY_ENQUIRY; ?></td>
			  </tr>
			  <tr>
				<td><?php echo tep_draw_textarea_field('enquiry', 'soft', 50, 15); ?></td>
			  </tr>
			</table></td>
		  </tr>
		</table></td>
	  </tr>

<?php
// BOF: Lango Added for template MOD
if (MAIN_TABLE_BORDER == 'yes'){
table_image_border_bottom();
}
// EOF: Lango Added for template MOD
?>
	  <tr>
		<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>
	  <tr>
		<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
		  <tr class="infoBoxContents">
			<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
			  <tr>
				<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
				<td align="right"><?php echo tep_template_image_submit('button_continue.gif', IMAGE_BUTTON_CONTINUE); ?></td>
				<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
			  </tr>
			</table></td>
		  </tr>
		</table></td>
	  </tr>
<?php
  }
?>
	</table></form>


it might be a problem with the following code, which has to be there at some points:

<?php
// BOF: Lango Added for template MOD
if (MAIN_TABLE_BORDER == 'yes'){
table_image_border_bottom();
}
// EOF: Lango Added for template MOD
?>


#74   pedro_vde

pedro_vde
  • Members
  • 6 posts
  • Real Name:Pedro Van der Eecken

Posted 12 April 2006 - 14:00

Thank You for the Contribution... JEEP!

I'm brand new to osCommerce - programming and even to Linux...
But thanks to these contributions our webshop is almost active

(www.image-sound.com/catalog)

kind regards from Belgium

Pedro

#75   Jeep_ice

Jeep_ice
  • Members
  • 150 posts
  • Real Name:Jean-Pierre

Posted 12 April 2006 - 15:34

Thank You for the Contribution... JEEP!

I'm brand new to osCommerce - programming and even to Linux...
But thanks to these contributions our webshop is almost active

(www.image-sound.com/catalog)

kind regards from Belgium

Pedro


Pedro,

Thank's to the kind words and welcome to the osCommerce communauty.
JEEP
--------------------
Installed Contributions:
osCommerce 2.2 Milestone MS2 + "Super Contact US Enhancement 1.1" + "Simple Template System (STS) 1.9" + "SPPC v.4.1.1" + "Column Product Listing for SPPC v4.1 v1.0" + "Quantity Price Breaks for SPPC 4.1.1"+ "Hide Price if $0 for "Quantity Price Breaks for SPPC 4.1.1" + "Show Price list for SPPC 4.1 v1.0"+ "EasyPopulate 2.72" + "Admin Reports Count Reset" + "Control Login 2.1" + "Credit card infobox" + "Customer Export" + "Customers Email and Phone in Order" + "Email for new customer 1.0" + "Handling fee" + "Phone Payment Credit Card Module 1.5" + "Purchase Orders version 1.3" + "Admin Comments Toolbar 4.0" + "Country-State Selector" + "Cart in Header for STS" + "Category Box Enhancement" + "Docs in Admin 1.0" + "Monthly Sales Report" + "Who's Online Enhancement" + "Whos Online 2.0" + "Simple Admin Access Control 1.2" and "Login box v2.2a" - Ouffffff !!! [img]http://forums.oscommerce.com/style_emoticons/default/smile.gif[/img]

#76   dreamlab

dreamlab
  • Members
  • 59 posts
  • Real Name:Dick
  • Gender:Male

Posted 19 April 2006 - 23:53

Hello,


Thank you for the wonderful contribution. I've just installed it, but all I receive in the email is the "Enquiry" text, no Name or Email Address in the body of the email.

Does this script normally add this information within the body of the email?

If not, is there any way to add this information to the body of email text?

My contact_us.php file is below. There are some minor modifications that do not affected the results, I have the same issue regardless.

BTW, if anyone knows how to add a new field for "company" to the email, that would be greatly appreciated.

Thank you in advance for your help!

Regards,

Dick

<?php
/*
  $Id: contact_us.php,v 1.42 2003/06/12 12:17:07 hpdl Exp $

  osCommerce, Open Source E-Commerce Solutions
  http://www.oscommerce.com

  Copyright (c) 2003 osCommerce

  Released under the GNU General Public License
*/

  require('includes/application_top.php');

  require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_CONTACT_US);

  $error = false;
  if (isset($HTTP_GET_VARS['action']) && ($HTTP_GET_VARS['action'] == 'send')) {
	$name = tep_db_prepare_input($HTTP_POST_VARS['name']);
	$email_address = tep_db_prepare_input($HTTP_POST_VARS['email']);
// BOF Super Contact us enhancement 1.0 
	$company = tep_db_prepare_input($HTTP_POST_VARS['company']);
	$enquiry = tep_db_prepare_input($HTTP_POST_VARS['enquiry']);
	$emailsubject = tep_db_prepare_input($HTTP_POST_VARS['reason']) . ' ' . EMAIL_SUBJECT;
	if (tep_validate_email($email_address)) {
	if (CONTACT_US_LIST !=''){
		$send_to_array=explode("," ,CONTACT_US_LIST);
		preg_match('/\<[^>]+\>/', $send_to_array[$send_to], $send_email_array);
		$send_to_email= eregi_replace (">", "", $send_email_array[0]);
		$send_to_email= eregi_replace ("<", "", $send_to_email);

		tep_mail(preg_replace('/\<[^*]*/', '', $send_to_array[$send_to]), $send_to_email, $emailsubject, $enquiry, $name, $email_address, $company);
	}else{
	  tep_mail(STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, $emailsubject, $enquiry, $name, $email_address, $company);
	}
// EOF Super Contact us enhancement 1.0 

	  tep_redirect(tep_href_link(FILENAME_CONTACT_US, 'action=success'));
	} else {
	  $error = true;

	  $messageStack->add('contact', ENTRY_EMAIL_ADDRESS_CHECK_ERROR);
	}
  }

  $breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_CONTACT_US));
?>
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo TITLE; ?></title>
<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">
<link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>
<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">
<!-- header //-->
<?php require(DIR_WS_INCLUDES . 'header.php'); ?>
<!-- header_eof //-->

<!-- body //-->
<table border="0" width="100%" cellspacing="0" cellpadding="0">
  <tr>
<!-- body_text //-->
	<td width="100%" valign="top"><?php echo tep_draw_form('contact_us', tep_href_link(FILENAME_CONTACT_US, 'action=send')); ?><table border="0" width="100%" cellspacing="0" cellpadding="0">
	  <tr>
		<td><table border="0" width="100%" cellspacing="0" cellpadding="0">
		  <tr>
			<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>
		  </tr>
		</table></td>
	  </tr>
	  <tr>
		<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>
<?php
  if ($messageStack->size('contact') > 0) {
?>
	  <tr>
		<td><?php echo $messageStack->output('contact'); ?></td>
	  </tr>
	  <tr>
		<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>
<?php
  }

  if (isset($HTTP_GET_VARS['action']) && ($HTTP_GET_VARS['action'] == 'success')) {
?>
	  <tr>
		<td class="main"><?php echo tep_image(DIR_WS_IMAGES . '', HEADING_TITLE, '0', '0', 'align="left"') . TEXT_SUCCESS; ?></td>
	  </tr>
	  <tr>
		<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
	  </tr>
	  <tr>
		<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">
		  <tr class="infoBoxContents">
			<td><table border="0" width="100%" cellspacing="0" cellpadding="2">
			  <tr>
				<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
				<td align="right"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image_button('button_continue.gif', IMAGE_BUTTON_CONTINUE) . '</a>'; ?></td>
				<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
			  </tr>
			</table></td>
		  </tr>
		</table></td>
	  </tr>
<!-- BOF Super Contact us enhancement 1.0 //-->
<?php
  } else {
  if (tep_session_is_registered('customer_id')) {
	$account_query = tep_db_query("select customers_firstname, customers_lastname, customers_email_address from " . TABLE_CUSTOMERS . " where customers_id = '" . (int)$customer_id . "'");
	$account = tep_db_fetch_array($account_query);

	$name = $account['customers_firstname'] . ' ' . $account['customers_lastname'];
	$email = $account['customers_email_address'];
  }
?>  

<tr>
	<td>
		<table border="0" width="100%" cellspacing="0" cellpadding="0">
			<tr> 
				<td width="290" height="0"></td>
				<td width="592"></td>
			</tr>
				
			<tr> 
				<td rowspan="11" valign="top"> <table width="100%" border="0" cellspacing="0" cellpadding="0">
					<tr>
					  <td width="10">&nbsp;</td>
					  <td width="200" class="main"><?php echo (CONTACT_INFO); ?></td>
					</tr>
				  </table></td>
				<td height="40" valign="top" class="main">
<?php 
		  if (CONTACT_US_LIST !=''){
					  echo SEND_TO_TEXT . '<br>';
				 if(SEND_TO_TYPE=='radio'){
				 foreach(explode("," ,CONTACT_US_LIST) as $k => $v) {
					if($k==0){
					$checked=true;
					}else{
					$checked=false;
					}
					echo tep_draw_radio_field('send_to', "$k", $checked). " " .preg_replace('/\<[^*]*/', '', $v);
				 }

			   }else{
				   foreach(explode("," ,CONTACT_US_LIST) as $k => $v) {
						$send_to_array[] = array('id' => $k, 'text' => preg_replace('/\<[^*]*/', '', $v));
					 }
				echo tep_draw_pull_down_menu('send_to',  $send_to_array);
			   }

			echo;
			}
?>
				</td> 
			</tr>
			<tr>
				<td height="40" valign="top" class="main">							
					<?php echo ENTRY_NAME; ?><br>
					<?php echo tep_draw_input_field('name'); ?>
				</td> 
			</tr>
			<tr> 
				<td height="4"></td>
			</tr>
			<tr> 
				<td height="40" valign="top" class="main">
					<?php echo ENTRY_EMAIL; ?><br>
					<?php echo tep_draw_input_field('email'); ?>
				</td> 
			</tr> 
				<td height="4"></td>
			</tr>
			<tr> 
				<td height="40" valign="top" class="main">
					<?php echo ENTRY_COMPANY; ?><br>
					<?php echo tep_draw_input_field('company'); ?>
				</td> 
			</tr> 
				<td height="4"></td>
			</tr>			
			<tr> 
				<td height="200" width="592" valign="top" class="main">
					<?php echo ENTRY_ENQUIRY; ?><BR>
					<!-- BOF This is the change for the Form Vunerability Fix //-->
					<?php echo tep_draw_textarea_field('enquiry', 'soft', 50, 15, tep_sanitize_string($_POST['enquiry']), '', false); ?>
					<!-- EOF This is the change for the Form Vunerability Fix //-->
				</td>
			</tr>
			<tr> 
				<td height="4"></td>
			</tr>
			<tr> 
				<td height="66" valign="top"><table width="100%" border="0" cellpadding="0" cellspacing="0">
					<tr> 
						<td width="547" height="62" valign="top" align="middle"><?php echo tep_image_submit('button_continue.gif', IMAGE_BUTTON_CONTINUE); ?></td>
					</tr>
				</table>
			</td>
		  </tr>
				</table>
				</td>
			</tr>
<?php
  }
?>
<!-- EOF Super Contact us enhancement 1.0 //-->
	</table></form></td>
<!-- body_text_eof //-->
  </tr>
</table>
<!-- body_eof //-->

<!-- footer //-->
<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>
<!-- footer_eof //-->
</body>
</html>
<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>


#77   Jeep_ice

Jeep_ice
  • Members
  • 150 posts
  • Real Name:Jean-Pierre

Posted 20 April 2006 - 14:36

Hello,
Thank you for the wonderful contribution. I've just installed it, but all I receive in the email is the "Enquiry" text, no Name or Email Address in the body of the email.

Does this script normally add this information within the body of the email?

If not, is there any way to add this information to the body of email text?

My contact_us.php file is below. There are some minor modifications that do not affected the results, I have the same issue regardless.

BTW, if anyone knows how to add a new field for "company" to the email, that would be greatly appreciated.

Thank you in advance for your help!

Regards,

Dick


Dick,

I will check your code today but You supposed to see all the information. Here an example of an email when you use my contrib below.

[img]http://www.icetronic.net/images/divers/Super_contact-email.jpg[/img]
JEEP
--------------------
Installed Contributions:
osCommerce 2.2 Milestone MS2 + "Super Contact US Enhancement 1.1" + "Simple Template System (STS) 1.9" + "SPPC v.4.1.1" + "Column Product Listing for SPPC v4.1 v1.0" + "Quantity Price Breaks for SPPC 4.1.1"+ "Hide Price if $0 for "Quantity Price Breaks for SPPC 4.1.1" + "Show Price list for SPPC 4.1 v1.0"+ "EasyPopulate 2.72" + "Admin Reports Count Reset" + "Control Login 2.1" + "Credit card infobox" + "Customer Export" + "Customers Email and Phone in Order" + "Email for new customer 1.0" + "Handling fee" + "Phone Payment Credit Card Module 1.5" + "Purchase Orders version 1.3" + "Admin Comments Toolbar 4.0" + "Country-State Selector" + "Cart in Header for STS" + "Category Box Enhancement" + "Docs in Admin 1.0" + "Monthly Sales Report" + "Who's Online Enhancement" + "Whos Online 2.0" + "Simple Admin Access Control 1.2" and "Login box v2.2a" - Ouffffff !!! [img]http://forums.oscommerce.com/style_emoticons/default/smile.gif[/img]

#78   owl17sb

owl17sb
  • Members
  • 75 posts
  • Real Name:sue paterson

Posted 06 May 2006 - 16:54

I am trying to install the "Super Contact Us Enhancement 1.1 and can't seem to get past step1 (typical newbie!!)

In the Readme file it sayS

Run the following MySQL query in phpMyadmin, or use the contact.sql file provided with this contribution.

INSERT INTO configuration SET configuration_title='Set "Contact Us" Email List', date_added=NOW(), sort_order='11', configuration_group_id='1', configuration_key='CONTACT_US_LIST', configuration_value= '', configuration_description='On the "Contact Us" Page, set the list of email addresses , in this format: Name 1 &lt;email@address1&gt;, Name 2 &lt;email@address2&gt;', use_function = NULL , set_function = NULL;

This is made to add your email departement via the admin panel. Go to the admin panel and :

Select Configuration
Select Store
Edit the section --> Set "Contact Us" Email List

And enter your email like this :

Example: Sales <sales@yourstore.com>, Support <support@yourstore.com> etc....


I don't know what it means when it says "Run the following MySQL query in PHPMyadmin so I have made a copy of my configuration.php file and have tried to amend that manually but I don't know where to "INSERT INTO.... at which point in my configure.php should I add this text.

Can anyone help - all I want to be able to do is add our Name and Address to the "Contact Us" form and this is the only contribution I can find that appears to do that.

Any help greatly appreciated
/smile.gif' class='bbc_emoticon' alt=':)' />

#79   athyholdt

athyholdt
  • Members
  • 35 posts
  • Real Name:Andreas

Posted 08 May 2006 - 12:29

I am trying to install the "Super Contact Us Enhancement 1.1 and can't seem to get past step1 (typical newbie!!)

In the Readme file it sayS

Run the following MySQL query in phpMyadmin, or use the contact.sql file provided with this contribution.

INSERT INTO configuration SET configuration_title='Set "Contact Us" Email List', date_added=NOW(), sort_order='11', configuration_group_id='1', configuration_key='CONTACT_US_LIST', configuration_value= '', configuration_description='On the "Contact Us" Page, set the list of email addresses , in this format: Name 1 <email@address1>, Name 2 <email@address2>', use_function = NULL , set_function = NULL;

This is made to add your email departement via the admin panel. Go to the admin panel and :

Select Configuration
Select Store
Edit the section --> Set "Contact Us" Email List

And enter your email like this :

Example: Sales <sales@yourstore.com>, Support <support@yourstore.com> etc....


I don't know what it means when it says "Run the following MySQL query in PHPMyadmin so I have made a copy of my configuration.php file and have tried to amend that manually but I don't know where to "INSERT INTO.... at which point in my configure.php should I add this text.

Can anyone help - all I want to be able to do is add our Name and Address to the "Contact Us" form and this is the only contribution I can find that appears to do that.

Any help greatly appreciated
/smile.gif' class='bbc_emoticon' alt=':)' />


Hi.
This means you need to run the MySql Query on the database, not on any of the php files. Download and install phpMyAdmin if you havent already. Then select your OSC database on the left and paste the query into a 'Run SQL Query' field and press Go.

#80   athyholdt

athyholdt
  • Members
  • 35 posts
  • Real Name:Andreas

Posted 08 May 2006 - 12:35

Hello and thanks for a great contribution.

It looks and works great.

I am looking to making it more secure agains user errors, so I wanted to send the emails to the correct department automatically.

Like this: Reason 1 gets sent to the webmaster, Reason 2 gets sent to order management and so on.

This eliminates the need for the email selection field on the form.

Unfortunately, my form coding is not up to par, so I dont know how to make the form select the proper email address based on the Reason selection.

Anyone?