Jump to content



Photo
- - - - -

why cant i turn cookies on?


This topic has been archived. This means that you cannot reply to this topic.
7 replies to this topic

#1   bgthomas

bgthomas
  • Members
  • 92 posts

Posted 16 February 2006 - 02:37

I am trying to turn cookies on but it keeps telling me that I do not have them turned on in my browser. But I do, in all three that i am testing with. Any ideas why this is happening or where I should go to read up on it?

Everytime I turn it on in admin and try to log into my account the following Cookie Usage screen comes up:





Cookie Usage

Cookie Privacy and Security

Cookies must be enabled to purchase online on this store to embrace privacy and security related issues regarding your visit to this site.

By enabling cookie support on your browser, the communication between you and this site is strengthened to be certain it is you who are making transactions on your own behalf, and to prevent leakage of your privacy information.

We have detected that your browser does not support cookies, or has set cookies to be disabled.

To continue shopping online, we encourage you to enable cookies on your browser.

For Internet Explorer browsers, please follow these instructions:
Click on the Tools menubar, and select Internet Options
Select the Security tab, and reset the security level to Medium
We have taken this measurement of security for your benefit, and apologize upfront if any inconveniences are caused.

Please contact the store owner if you have any questions relating to this requirement, or to continue purchasing products offline.

#2   toyicebear

toyicebear
  • Community Sponsor
  • 6,411 posts

Posted 16 February 2006 - 03:14

I am trying to turn cookies on but it keeps telling me that I do not have them turned on in my browser. But I do, in all three that i am testing with. Any ideas why this is happening or where I should go to read up on it?

Everytime I turn it on in admin and try to log into my account the following Cookie Usage screen comes up:
Cookie Usage

Cookie Privacy and Security

Cookies must be enabled to purchase online on this store to embrace privacy and security related issues regarding your visit to this site.

By enabling cookie support on your browser, the communication between you and this site is strengthened to be certain it is you who are making transactions on your own behalf, and to prevent leakage of your privacy information.

We have detected that your browser does not support cookies, or has set cookies to be disabled.

To continue shopping online, we encourage you to enable cookies on your browser.

For Internet Explorer browsers, please follow these instructions:
Click on the Tools menubar, and select Internet Options
Select the Security tab, and reset the security level to Medium
We have taken this measurement of security for your benefit, and apologize upfront if any inconveniences are caused.

Please contact the store owner if you have any questions relating to this requirement, or to continue purchasing products offline.



That is probably caused by an incorect cookie path setting in this file: includes/configure.php

#3   AlanR

AlanR
  • Members
  • 3,711 posts

Posted 16 February 2006 - 03:28

If you're using shared ssl you can not use "Force Cookies".

See: http://forums.oscomm...ndpost&p=764018
Local: Mac OS X 10.5.8 - Apache 2.2/php 5.3.0/MySQL 5.4.10 • Web Servers: Linux
Tools: BBEdit, Coda, Versions (Subversion), Sequel Pro (db management)

#4   potte

potte
  • Members
  • 1 posts

Posted 20 February 2006 - 19:33

That is probably caused by an incorect cookie path setting in this file: includes/configure.php


I had this same problem and I solved it by opening the configure.php file mentioned above (in the includes folder). Once I verified that 'HTTP_SERVER' and 'HTTPS_SERVER' were defined correctly in lines 14 and 15, I made sure that 'HTTP_COOKIE_DOMAIN', 'HTTPS_COOKIE_DOMAIN', 'HTTP_COOKIE_PATH', and 'HTTPS_COOKIE_PATH' were empty on lines 17-20; that is, that there was no path specified in between the single quotes. Then the login screen came up.

#5   Vger

Vger
  • Members
  • 16,978 posts

Posted 20 February 2006 - 23:51

I made sure that 'HTTP_COOKIE_DOMAIN', 'HTTPS_COOKIE_DOMAIN', 'HTTP_COOKIE_PATH', and 'HTTPS_COOKIE_PATH' were empty on lines 17-20; that is, that there was no path specified in between the single quotes. Then the login screen came up.


Fine - but can your website keep a session trail?

Vger

#6   roseco

roseco
  • Members
  • 30 posts

Posted 24 February 2006 - 16:09

I am getting exactly the same problem, I do not have ssl enabled on my server and whatever I do on the includes/configure.php file I keep getting the cookie_usage page.

Can anyone give a definitive example of the settings that should be used please?

Thanks.

#7   Vger

Vger
  • Members
  • 16,978 posts

Posted 24 February 2006 - 17:14

define('HTTP_SERVER', 'http://www.yourdomain.com');
define('HTTPS_SERVER', '');
define('ENABLE_SSL', false);
define('HTTP_COOKIE_DOMAIN', 'www.yourdomain.com');
define('HTTPS_COOKIE_DOMAIN', '');
define('HTTP_COOKIE_PATH', '/');
define('HTTPS_COOKIE_PATH', '');
define('DIR_WS_HTTP_CATALOG', '/');
define('DIR_WS_HTTPS_CATALOG', '');

Vger

#8   roseco

roseco
  • Members
  • 30 posts

Posted 24 February 2006 - 17:42

Thank you so much Vger, I have spent all day on this and now it works!