Jump to content

* * * * * 4 votes

Official PayPal IPN Support Thread

  • Please log in to reply
4142 replies to this topic

#4141   radhavallabh

  • Members
  • 133 posts
  • Real Name:sunil jain
  • Gender:Male
  • Location:New Delhi India

Posted 23 September 2014 - 06:00

Hi everyone

Using Paypal Official 3.2 version on oscommerce 2.3.4-

I am using checkout_process.php on Autoreturn URL


I am facing same issue below like greasemonkey-


......., I have a small issue which I cannot seemt to sort out.

When a customer pays with Paypal the customers country is not getting transferred to the order process email???

It looks like below:

Delivery Address
Jane Dow
1121 Main St E
Toronto, M1M 1M1

Billing Address
Jane Dow
1121 Main St E
Toronto, M1M 1M1

It seems to work fine when a customer pays with my other payment module... Only when they choose paypal?

I have looked at the following code in ipn.php

         $email_order .= "\n" . EMAIL_TEXT_DELIVERY_ADDRESS . "\n" .
                         EMAIL_SEPARATOR . "\n" .
     tep_address_format($order->delivery['format_id'], $order->delivery, 0, '', "\n") . "\n";
         $email_order .= "\n" . EMAIL_TEXT_BILLING_ADDRESS . "\n" .
                         EMAIL_SEPARATOR . "\n" .
     tep_address_format($order->billing['format_id'], $order->billing, 0, '', "\n") . "\n\n";
I have tried to take snippets from checkout_process.... but no luck... any ideas?


Could anyone help on this....

#4142   sakkiotto

  • Members
  • 67 posts
  • Real Name:manuel

Posted 23 March 2015 - 19:12

Hi, i have problem for calculate paypal fee... can you help me?

#4143   Yak39

  • Members
  • 79 posts
  • Real Name:Francesco Rossi

Posted 26 August 2015 - 06:25

Hello I'm using an old release of PayPal IPN Official, the last compatible with 2.2.

I have been using the release for two years without a scratch. Last week express_checkout.php returned an error 500.

Looking at the server's log the only information I have is the following:

" End of script output before headers"


 the error feedback is not enough for me to understand what happened. I immediately though our hosters changed something in the PHP version our space is running but I have received confirmation nothing has changed in the server's configuration.

 Can anybody help me guess what happened?

Thank you