Jump to content



Photo
- - - - -

[contribution support] Custom META Tags per ITEM


  • Please log in to reply
86 replies to this topic

#21   EricK

EricK
  • Members
  • 315 posts
  • Real Name:Eric_K
  • Gender:Male
  • Location:Atlanta, GA USA

Posted 02 April 2006 - 19:37

This contribution works like a charm, however Search and Advanced Search do not query the Custom META tags fields. This is likely by design, however I need cart search to include the custom meta tags.

How would I extend cart search to query the Custom META tags fields in the database?

Thanks,
EricK

#22   lsolomontx

lsolomontx
  • Members
  • 2 posts
  • Real Name:Laura Solomon

Posted 17 April 2006 - 23:23

This is the support link for the 'Custom META Tags per ITEM' contribution.

Here's the contribution link:
Custom META Tags per ITEM - Contribution

Custom META Tags per Item v1.0

This contribution allows you to set which META Tags & page TITLE are displayed on a per-product, per-category, and per-subCategory basis. This is an important step towards SEO! The following custom fields are stored in the database for each product, category, & subcategory:
META Keywords
META Description
TITLE (i.e. <TITLE></TITLE>)

This can be used to set default META Tags & page TITLE for your entire OSC store. If a product or category doesn't have an entry for any of the 3 custom fields, it will display the default for those fields.

All entries are controlled using the admin console.

Multi-language is supported for the product tags.

Extra fields are added to the database to hold the custom fields, so this contribution should be very benign in it's interaction with other contributions.

I heavily modified & extended Daniel Richards original 'custom meta tags' contribution to include extra fields, multi-language capabilities, and extra functionality.

This contribution has been tested with Ultimate SEO URLs.

I hope this helps y'all place well in the search engines! /biggrin.gif' class='bbc_emoticon' alt=':D' />

-Randelia



#23   lsolomontx

lsolomontx
  • Members
  • 2 posts
  • Real Name:Laura Solomon

Posted 17 April 2006 - 23:25

PLEASE HELP!! Beyond frustration, cannot get this script to work with OscMax.

#24   CurioPete

CurioPete
  • Members
  • 18 posts
  • Real Name:Pete

Posted 25 April 2006 - 10:58

I have had this contib installed for a few weeks now.
It seemed to work (mostly for the index page) when I installed it, and search engines were picking up the site. But now I have'nt had a search engine (or even an unwanted spider) crawl my site in over two weeks.

Anyone have any theories about whether this contrib actually works?

#25   Pink

Pink
  • Members
  • 96 posts
  • Real Name:Robert Pinkham

Posted 21 May 2006 - 22:16

This is the support link for the 'Custom META Tags per ITEM' contribution.

Here's the contribution link:
Custom META Tags per ITEM - Contribution

Custom META Tags per Item v1.0

This contribution allows you to set which META Tags & page TITLE are displayed on a per-product, per-category, and per-subCategory basis. This is an important step towards SEO! The following custom fields are stored in the database for each product, category, & subcategory:
META Keywords
META Description
TITLE (i.e. <TITLE></TITLE>)

This can be used to set default META Tags & page TITLE for your entire OSC store. If a product or category doesn't have an entry for any of the 3 custom fields, it will display the default for those fields.

All entries are controlled using the admin console.

Multi-language is supported for the product tags.

Extra fields are added to the database to hold the custom fields, so this contribution should be very benign in it's interaction with other contributions.

I heavily modified & extended Daniel Richards original 'custom meta tags' contribution to include extra fields, multi-language capabilities, and extra functionality.

This contribution has been tested with Ultimate SEO URLs.

I hope this helps y'all place well in the search engines! /biggrin.gif' class='bbc_emoticon' alt=':D' />

-Randelia


I installed your contribution on a test site on a local machine and it seems to work fine.

However, when I installed it on two online shops, only the default tags I entered in /includes/functions/general.php show up. phpMyAdmin indicates that my entries are present in the database.

Everything seems to be the same as far as I can tell for both the local and remote sites. I am baffled. Help would be appreciated.

-Pink

#26   djbastard

djbastard
  • Members
  • 8 posts
  • Real Name:Jochem

Posted 03 June 2006 - 20:00

I need help :S

I installed the contribution and ran into a little problem

the shop side is oke and shows up correctly but when i go into the admin and then go to catalog (admin/categories.php?selected_box=catalog) it says:

Parse error: syntax error, unexpected T_ELSE in /home/realwear/public_html/shop/admin/categories.php on line 949.

when i open up categories.php then these are the lines

//rmh M-S_multi-stores begin
} else {
echo TEXT_UNAUTHORIZED_ACCESS;
}
//rmh M-S_multi-stores end
} elseif ($action == 'new_product_preview') {
if (tep_not_null($HTTP_POST_VARS)) {
$pInfo = new objectInfo($HTTP_POST_VARS);
$products_name = $HTTP_POST_VARS['products_name'];
$products_description = $HTTP_POST_VARS['products_description'];
$products_url = $HTTP_POST_VARS['products_url'];
} else {
//rmh M-S_multi-stores begin
// big image amended
// +Randelia Custom_META_Tags_Per_Item
$products_keywords = $HTTP_POST_VARS['products_keywords'];
$products_metadescription = $HTTP_POST_VARS['products_metadescription'];
$products_pagetitle = $HTTP_POST_VARS['products_pagetitle'];
} else {
$product_query = tep_db_query("select p.products_id, pd.language_id, pd.products_name, pd.products_description, pd.products_url, pd.products_keywords, pd.products_metadescription, pd.products_pagetitle, p.products_quantity, p.products_model, p.products_image, p.products_mediumimage, p.products_largeimage, p.products_price, p.products_qty_blocks, p.products_weight, p.products_date_added, p.products_last_modified, p.products_date_available, p.products_status, p.manufacturers_id from " . TABLE_PRODUCTS . " p, " . TABLE_PRODUCTS_DESCRIPTION . " pd " . ($admin_allowed_stores[0] == '*' ? " " : " LEFT JOIN " . TABLE_PRODUCTS_TO_STORES . " p2s ON p.products_id = p2s.products_id ") . "where p.products_id = pd.products_id and p.products_id = '" . (int)$HTTP_GET_VARS['pID'] . "'". ($admin_allowed_stores[0] == '*' ? " " : " and p2s.stores_id in(" . implode(',' , $admin_allowed_stores) . ")"));
// -Randelia Custom_META_Tags_Per_Item

$product = tep_db_fetch_array($product_query);
if (tep_not_null($product) && (tep_is_product_distributor($HTTP_GET_VARS['pID']) == true)) {
$pInfo = new objectInfo($product);
}
$products_image_name = $pInfo->products_image;
// Big Image Start
$products_mediumimage_name = $pInfo->products_mediumimage;
$products_largeimage_name = $pInfo->products_largeimage;
// Big Image End
}

$form_action = (isset($HTTP_GET_VARS['pID']) && (tep_is_product_distributor($HTTP_GET_VARS['pID']) == true)) ? 'update_product' : 'insert_product';
echo tep_draw_form($form_action, FILENAME_CATEGORIES, 'cPath=' . $cPath . ((isset($HTTP_GET_VARS['pID']) && (tep_is_allowed_product($HTTP_GET_VARS['pID']))) ? '&pID=' . $HTTP_GET_VARS['pID'] : '') . '&action=' . $form_action, 'post', 'enctype="multipart/form-data"');
//rmh M-S_multi-stores end


NOTE: } else { = line 949


I have the multi stores & big images contribution installed

can anyone help me with this??? I need it much because i only have 1 page in Google :S


thnx in advance

#27   aaronpang

aaronpang
  • Members
  • 7 posts
  • Real Name:Aaron Pang

Posted 26 July 2006 - 13:40

:'( Hi There,

I just have a few dumb questions regarding this contribution pack.

How do I run a SQL script? And which installation method can be easily executed for a starter like myself?
Would you have an installation guidline for me?

Thanks alot for answering my queries.


Have a great night!

Aaron

#28   lisa65

lisa65
  • Members
  • 83 posts
  • Real Name:Lisa65

Posted 03 August 2006 - 21:16

Hello Everyone,

I have added 3 contributions to my cart , MVS, xsell and category descriptions. I would like to know how well the Custom META Tags per ITEM works with these contributions. I am mostly concerned with the category descriptions. If anyone is running a similar combination of contributions or has any info regarding this would you mind posting it for me here?

Thanks,

Lisa

#29   lisa65

lisa65
  • Members
  • 83 posts
  • Real Name:Lisa65

Posted 06 August 2006 - 02:12

Well, considering the lack of response I went ahead and installed the contribution. It works just fine but I had modify my installation a little to avoid messing up my installation of MVS.

Great contribution but maybe the addition of custom category meta tags could be added someday.

Thanks for the contribution.

Lisa

#30   lisa65

lisa65
  • Members
  • 83 posts
  • Real Name:Lisa65

Posted 07 August 2006 - 18:48

Is anyone supporting the contribution?

My custom meta tags are being generated for categories but I can't seem to get the custom tags to show for products. They have the defaults even though I have defined custom tags.

Thanks,

Lisa

#31   oskenny

oskenny
  • Members
  • 2 posts
  • Real Name:Kenny Hsu

Posted 28 August 2006 - 07:43

Hi everyone /biggrin.gif' class='bbc_emoticon' alt=':D' /> ,

Love this contribute! Got a question, is there a way to dynamically set the meta tags and page titles using the original product information?

Page title = The Product name + Store name
Keywords = Keywords set in general + The product name
Description = The Product's description

Instead of setting each product keywords and description individually in the admin.

Many thanks for your help, /thumbsup.gif' class='bbc_emoticon' alt=':thumbsup:' />

Kenny

#32   EricK

EricK
  • Members
  • 315 posts
  • Real Name:Eric_K
  • Gender:Male
  • Location:Atlanta, GA USA

Posted 28 August 2006 - 14:17

Kenny,

cDynamic Meta Tags v1.0

Regards,
EricK

#33   oskenny

oskenny
  • Members
  • 2 posts
  • Real Name:Kenny Hsu

Posted 28 August 2006 - 15:39

Kenny,

cDynamic Meta Tags v1.0

Regards,
EricK


Thanks a lot Erick /thumbsup.gif' class='bbc_emoticon' alt=':thumbsup:' /> I will look into that

Kenny

#34   loudnclr1

loudnclr1
  • Members
  • 34 posts
  • Real Name:Michael

Posted 02 September 2006 - 00:28

Hi,

I would like to thank you, Randelia for your contribution - Custom MetaTag Per Item!

I just have one question.
I keep getting this error message when I click on the category or the manufacturer list:

1054 - Unknown column 'p.products_id' in 'on clause'

select count(p.products_id) as total from products_description pd, products p left join manufacturers m on p.manufacturers_id = m.manufacturers_id, products_to_categories p2c left join specials s on p.products_id = s.products_id where p.products_status = '1' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '1' and p2c.categories_id = '69'

[TEP STOP]



Could anyone please help me as I have to get this site up and running ASAP.

Thank You!

#35   LOSHANNESSY

LOSHANNESSY
  • Members
  • 172 posts
  • Real Name:Liam

Posted 15 October 2006 - 05:28

i have this contribution installed, but only the catagory meta tags/titles show up. the items for some reason display the default meta tags/titles... does anyone know why this would be occuring?

#36   lisa65

lisa65
  • Members
  • 83 posts
  • Real Name:Lisa65

Posted 15 October 2006 - 15:26

i have this contribution installed, but only the catagory meta tags/titles show up. the items for some reason display the default meta tags/titles... does anyone know why this would be occuring?


I have the same problem but still haven't found any help for the problem.

Lisa

#37   lisa65

lisa65
  • Members
  • 83 posts
  • Real Name:Lisa65

Posted 28 October 2006 - 19:26

Lot's of problems but no help! Has anyone installed this script that can help?

#38   busymum

busymum
  • Members
  • 11 posts
  • Real Name:Meghan

Posted 04 November 2006 - 19:01

Lot's of problems but no help! Has anyone installed this script that can help?


Am having a similar problem. I got the title tag to show up for each product but it's still showing the default description and default keywords tags in the source code instead of the custom ones set in the admin panel. Can't see where I went wrong in the install and don't know why it's not showing the correct meta tags. Can anyone help with this? Thanks.

#39   Kam Racing

Kam Racing
  • Members
  • 8 posts
  • Real Name:jon

Posted 07 November 2006 - 21:20

Am having a similar problem. I got the title tag to show up for each product but it's still showing the default description and default keywords tags in the source code instead of the custom ones set in the admin panel. Can't see where I went wrong in the install and don't know why it's not showing the correct meta tags. Can anyone help with this? Thanks.


I have noticed on my install that when on the "Configuration - My Store" page, the "Use Search-Engine Safe URLs" is set to true, it does not show the specified meta tags for the product page. When it is set to false it shows them.... Is this the same error that everyone else is getting? Does any one know how to fix this?

#40   Kam Racing

Kam Racing
  • Members
  • 8 posts
  • Real Name:jon

Posted 07 November 2006 - 21:25

/sad.gif' class='bbc_emoticon' alt=':(' /> I am having a few errors, when I go to edit a product, all of the products information is removed and gone? And the two errors are shown:
Could this be something to do with the database being edited via the script?

Thanks



i got this when i first installed the module (I did the line by line code update)... to solve it i uploaded the files supplied from the admin and the categories.php and then redid my modifications to those files.. i've just got the issue with the "Use Search-Engine Safe URLs" to fix

Edited by Kam Racing, 07 November 2006 - 21:27.