Jump to content



Photo
- - - - -

http://localhost/index.php/localhost...?????


This topic has been archived. This means that you cannot reply to this topic.
5 replies to this topic

#1   Urbluffingme

Urbluffingme
  • Members
  • 262 posts

Posted 27 March 2005 - 01:58

I have been using osCommerce for a while and love it. I had some problems and had to reformat and do a fresh install of XP, MySQL, PHP, and Apache on my local machine. I grabbed all my files and db from my web host and got everything set up on my local machine.

My page displays fine and the products populate, but when I click on a product (or any other link for that matter) I get a 404 error because the URL =
http://localhost/index.php/localhost......

How can I change this?

Edited by Urbluffingme, 27 March 2005 - 01:58.


#2   Urbluffingme

Urbluffingme
  • Members
  • 262 posts

Posted 27 March 2005 - 02:30

its actually localhost/localhost/account.php

Edited by Urbluffingme, 27 March 2005 - 02:31.


#3   Geotex

Geotex
  • Members
  • 633 posts

Posted 27 March 2005 - 03:32

its actually localhost/localhost/account.php

<{POST_SNAPBACK}>


The error is in your configure.php files.

btw.. did you create a local configure.php and instal it in includes/local folder? that way, you can maintain your website configure.php and local/configure.php, and don't always have to change the file when you upload all your files.

Also, you should put the website and shop files in a subdirectory on your local host. everything seems to work better that way, especially if you want to try some different version.

hth
GEOTEX from Houston, TX

(George)

#4   Urbluffingme

Urbluffingme
  • Members
  • 262 posts

Posted 27 March 2005 - 06:01

I tried a bunch of different things in configure.php and admin/..../configure.php, but came up short. as for the seperate config files for local and production, I upload files one at a time as I alter them, so its not an issue really. thanks though.

#5   Geotex

Geotex
  • Members
  • 633 posts

Posted 27 March 2005 - 06:23

I tried a bunch of different things in configure.php and admin/..../configure.php, but came up short.  as for the seperate config files for local and production, I upload files one at a time as I alter them, so its not an issue really.  thanks though.

<{POST_SNAPBACK}>


I guess this is a dumb question, but...

Did you actually install osCommerce on your computer then do a restore on the database with your old website data, or just copy the files and try to rewrite the config? One way works, the other may not...
GEOTEX from Houston, TX

(George)

#6   Urbluffingme

Urbluffingme
  • Members
  • 262 posts

Posted 27 March 2005 - 17:34

well, I didnt do a fresh install of osc because I have all kinds of contributions iunstalled and made modifications. I just dropped the directory containing my site files in my server root folder and then loaded my db on my MYSQL server. then I made the changes in configure.php. I know it has to be one freakin setting somewhere I just cant find it.

The site works fine. All the database calls work fine. Whatever I click on, if I manually remove the extra '/localhost/ from the URL, everything displays fine. If this helps, clicking on the shopping cart and login.php buttons points you to the right URL. Every other button or link adds the extra '/localhost/'

/crying.gif' class='bbc_emoticon' alt=':'(' /> /crying.gif' class='bbc_emoticon' alt=':'(' /> /crying.gif' class='bbc_emoticon' alt=':'(' />