Jump to content



Photo
- - - - -

Quickly Update Product Stock


  • Please log in to reply
184 replies to this topic

#121   azrin_aris

azrin_aris
  • Members
  • 34 posts
  • Real Name:Azrin Aris

Posted 01 April 2009 - 03:48

Hi jhande,

1. I put V3.5 on both an 2.2rc2a and 2.2ms2
2.2rc2a just logs me out everytime i try to update
2.2ms2 either tells me that no products have been updated or updates like a minimal amount of them

2. My products are in the 3rd category down so cat-subcat-subsubcat-products
3. I rolled back from 3.7 to 3.5 hoping that might make a difference (apperently not)
4. I've tried updating price, stock & status
5. I've ticked the box at times, the times i've ticked it, it does onthing

So i did some experimenting on my 2.2rc2a install and found that (with v3.7) if a category contained upto 24 products, everything would be fine, if there were 25 or more, then it would log me out everytime i hit the update button.

Hope that helps.

Mike


Sorry guys, I was silent for quite sometimes.... Today I'm on leave so I had a chance to log in here /smile.gif' class='bbc_emoticon' alt=':)' />

Mike, My products are more than 3 level deep and so far it is working ok. I'm working on a copy function so that we can further sub categorize the parts/items that I have. As for your problem, I would like to suggest that you try it on a clean OSC. Please let me know the result.

Since I seldom log in to this forum, if you have any problem, you can email me directly azrin_aris at yahoo dot com. or msn at azrin dot aris at live dot com. I will try as much as I could....

#122   kobou

kobou
  • Members
  • 9 posts
  • Real Name:kobou

Posted 08 April 2009 - 20:20

Hi,

i have the following problem

I installed v3.7 at my local testing server and works perfectly.

When i transfer my installation on the web when i try to choose anything fromthe pull down menu it just redirevts me to admin login page!!!!!!!!!

Please help me

#123   AndreD

AndreD
  • Members
  • 149 posts
  • Real Name:André Kjellstrup

Posted 17 April 2009 - 11:39

When i transfer my installation on the web when i try to choose anything fromthe pull down menu it just redirevts me to admin login page!!!!!!!!!


I guess you did not update filenames -file.

#124   AndreD

AndreD
  • Members
  • 149 posts
  • Real Name:André Kjellstrup

Posted 17 April 2009 - 11:43

Strange problem - no items updated.

If I update anything in a large category, submitting the update (after clicking "update") takes some time... and then nothing is updated, and I am back to category selection (NOT seeing the category I cose before)

Any smaller category works fine, items are updated, and then I still can see the selected category.

I guess there is some timeout - but where ?

Edited by AndreD, 17 April 2009 - 11:44.


#125   jhande

jhande
  • Members
  • 2,236 posts
  • Real Name:Jim Hande
  • Gender:Male
  • Location:Keene, NH USA

Posted 17 April 2009 - 18:44

I'm hoping I can help clear up a few problems people seem to be having lately, but keep in mind I'm no expert! /blush.gif' class='bbc_emoticon' alt=':blush:' />

Version 7 is NOT a complete package, it is an update. First install v3.5 15 Dec 2008, test it, and then v3.7 Beta 24 Jan 2009 both by Azin Aris.

I wouldn't think that a problem would lie when using RC2 compared with using MS2 2.2 as far as stock not updating correctly. I have successfully updated 300 products in a level 3 category. My quess would be a script time-out (as long as the installation was done properly). One place to check is in your php.ini file. This is what I have and works fine with my slow dialup -
;;;;;;;;;;;;;;;;;;;
; Resource Limits ;
;;;;;;;;;;;;;;;;;;;

max_execution_time = 30 ; Maximum execution time of each script, in seconds
memory_limit = 32M ; Maximum amount of memory a script may consume (8MB)

There might be other places to check for time-outs but I'm not proficient with that. If you are using a good hosting company you can contact them and ask why when you run an SQL script to update said amount of items in a database, only some get updated. They should be able to point you in the right direction as to where and what setting(s) need to be changed. It might even be something they can fix for you.

I know I haven't been much help but I tried! /happy.gif' class='bbc_emoticon' alt='^_^' />
- :: Jim :: -
- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

#126   AndreD

AndreD
  • Members
  • 149 posts
  • Real Name:André Kjellstrup

Posted 20 April 2009 - 15:37

Thanks for trying to help, the server uses already 60secs timeout.
I have my hosting company to look at it.

#127   jhande

jhande
  • Members
  • 2,236 posts
  • Real Name:Jim Hande
  • Gender:Male
  • Location:Keene, NH USA

Posted 20 April 2009 - 21:30

Thanks for trying to help, the server uses already 60secs timeout.
I have my hosting company to look at it.


That's probably the best. Whenever I come across a strange problem I call my host and they check error logs that I can't access. Then they either tell me what and how to fix it or they do it for me.

Good luck /wink.gif' class='bbc_emoticon' alt=';)' />
- :: Jim :: -
- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

#128   AndreD

AndreD
  • Members
  • 149 posts
  • Real Name:André Kjellstrup

Posted 23 April 2009 - 10:00

My host found the problem: they needed to change a limit in suhosin - now it works perfectly.

#129   jhande

jhande
  • Members
  • 2,236 posts
  • Real Name:Jim Hande
  • Gender:Male
  • Location:Keene, NH USA

Posted 23 April 2009 - 15:41

Awesome!

Glad to hear you have it fixed André /wink.gif' class='bbc_emoticon' alt=';)' />
- :: Jim :: -
- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

#130   jimbob_pooley

jimbob_pooley
  • Members
  • 4 posts
  • Real Name:Steve

Posted 23 April 2009 - 20:29

Hello all,

Just thought I'd pass on a 'bug fix' I found the other day when fiddling about with this great contrib. It's not really a bug, but some people may find the following useful.

If, like me, you have a shop which doesn't have Manufacturers, the corresponding Manufacturers drop down list will be blank/Null. If you're running STRICT mode on MySQL, quick_stock will report that it has updated the item(s) (i.e. the stock number), but not actually run the script.

As far as I can work out MySql in Strict Mode doesn't like running an SQL statement with a NULL or empty value for the Manufacturer field. I added the following code [codebox]if ($items['manufacturer'] == '') {$items['manufacturer']=0;}[/codebox]

before the $sql variable is defined (somewhere round about line 377)

Of course, the other alternative is to have a dummy manufacturer.

Cheers

#131   azrin_aris

azrin_aris
  • Members
  • 34 posts
  • Real Name:Azrin Aris

Posted 06 May 2009 - 02:37

Hello all,

Just thought I'd pass on a 'bug fix' I found the other day when fiddling about with this great contrib. It's not really a bug, but some people may find the following useful.

If, like me, you have a shop which doesn't have Manufacturers, the corresponding Manufacturers drop down list will be blank/Null. If you're running STRICT mode on MySQL, quick_stock will report that it has updated the item(s) (i.e. the stock number), but not actually run the script.

As far as I can work out MySql in Strict Mode doesn't like running an SQL statement with a NULL or empty value for the Manufacturer field. I added the following code

if ($items['manufacturer'] == '') {$items['manufacturer']=0;}

before the $sql variable is defined (somewhere round about line 377)

Of course, the other alternative is to have a dummy manufacturer.

Cheers



Thanks for the bug fix, I'll look into it. BTW, I have release a new version 3.8. but your bugfix is not in yet. Will put it in the next release

Cheers
Azrin

Edited by azrin_aris, 06 May 2009 - 02:40.


#132   azrin_aris

azrin_aris
  • Members
  • 34 posts
  • Real Name:Azrin Aris

Posted 06 May 2009 - 02:51

I tried to upload a new version v3.8 but I was unable to upload the files. Anybody knows why?

#133   azrin_aris

azrin_aris
  • Members
  • 34 posts
  • Real Name:Azrin Aris

Posted 06 May 2009 - 10:26

I tried to upload a new version v3.8 but I was unable to upload the files. Anybody knows why?



Ok got it to work!!

#134   azrin_aris

azrin_aris
  • Members
  • 34 posts
  • Real Name:Azrin Aris

Posted 06 May 2009 - 10:56

Found a bug
I'm using this configuration for Currency Localization :
Decimal point : ,
Thousand point : .

When I update the price, the price went wrong. for example original price was 10000 it shows 10,000 in quick updater.
I update the stock, leave the price as it is. when i check the store, the price is 10, back to the updater, yup it's a 10.
I dont know a thing about php. To work this out i set the decimal and thousand point back to default.

Thx for this Azrin, its great.



Hi Ferdi, please test the new release. I think i got it fixed.

thanks for pointing this out.

Cheers
Azrin

#135   azrin_aris

azrin_aris
  • Members
  • 34 posts
  • Real Name:Azrin Aris

Posted 06 May 2009 - 10:59

Hi (agian),

Just been testing it out. It seems to only want to update selective products, some items it refuses to change, but with others. no problems at all.

No clue why.



Hi Mike,

The reason why it is not updating is because there are errors in the sql statements that are not properly capture (sorry /sad.gif' class='bbc_emoticon' alt=':(' /> ) please try the v3.8 and let me know if you still have the same problem

Cheers

Azrin

#136   azrin_aris

azrin_aris
  • Members
  • 34 posts
  • Real Name:Azrin Aris

Posted 06 May 2009 - 11:01

Hi,

Great Mod firstly /biggrin.gif' class='bbc_emoticon' alt=':D' />

Is there any chance of getting a column which has the prices including taxes? or just have a toggle option so we can select which prices we want to see.

Cheers,
Mike



Hi Mike,

Can you please explain more about this feature?

Cheers
Azrin

#137   azrin_aris

azrin_aris
  • Members
  • 34 posts
  • Real Name:Azrin Aris

Posted 06 May 2009 - 13:22

So far with my testing all is working great.
I can sort by Manufacturers or Categories, change the weight, price, qty and status of products quickly.
I can change the status of my products to show "On Backorder" simply by subtracting the QTY (In Stock = 3 / New Stock = -3). I have the function of the show sold out contribution setup so when stock qty reaches zero it shows On Backorder, when I change the status to not-active it removes the product from the catalog view.


The Active/Inactive is suppose to take the items in/out of the store. To set Back Order or Sold out, set Qtty to 0. /smile.gif' class='bbc_emoticon' alt=':)' />


The only thing I changed was the sort order from product name to product model.
I don't really have a need for the feature of being able to change the model number or category from the page. But it might come in handy in the future if I need to re-organize my site.


I'm working on this feature - so we can sort on any colum /biggrin.gif' class='bbc_emoticon' alt=':D' />


I like how it displays the product ID. Would it be difficult to add the category ID next to it?


I've added this feature but with a bit of twist - hover you mouse over the selection box and it will show you the category /smile.gif' class='bbc_emoticon' alt=':)' />. Let me know if I got this wrong

I have a couple of weeks free time untill 24 of May.... yay!!!

#138   jhande

jhande
  • Members
  • 2,236 posts
  • Real Name:Jim Hande
  • Gender:Male
  • Location:Keene, NH USA

Posted 13 May 2009 - 18:07

The Active/Inactive is suppose to take the items in/out of the store. To set Back Order or Sold out, set Qtty to 0. /smile.gif' class='bbc_emoticon' alt=':)' />

Oop's, that's kind of how I meant I do it. Qty = 0 = Back Order, Status = Inactive = Not listed in catalog. /blush.gif' class='bbc_emoticon' alt=':blush:' />

I'm working on this feature - so we can sort on any colum /biggrin.gif' class='bbc_emoticon' alt=':D' />

That would be nice. Right now I'm happy with sorting by the model number, it works LOL.

I've added this feature but with a bit of twist - hover you mouse over the selection box and it will show you the category /smile.gif' class='bbc_emoticon' alt=':)' /> . Let me know if I got this wrong

Perfect! Thanks a million. /wink.gif' class='bbc_emoticon' alt=';)' />

I have a couple of weeks free time untill 24 of May.... yay!!!

Hope you get to enjoy some sunshine and fun, not just coding. /cool.gif' class='bbc_emoticon' alt='B)' />


I just ran the uninstall SQL, ran the new install SQL (probably didn't need too).
Checked all files for updates, were none except replacing the admin files (quick_stockupdate.php, quick_stockupdate.css and english > quick_stockupdate.php).

I haven't tried updating any products yet, will work on that a bit later.

I'm experiencing what seems to be a couple of glitches.

When I select "Search by - Manufacturer", I get one product that shows automatically (first alphanumerical - AMT/608). Could live with that, no biggy.

But once I select a Manufacturer, the Category column is greyed out and can't be selected. Is that supposed to function that way?

I appreciate all the work and effort you're putting into this great contribution, BIG thanks Azrin /biggrin.gif' class='bbc_emoticon' alt=':D' />
- :: Jim :: -
- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -

#139   azrin_aris

azrin_aris
  • Members
  • 34 posts
  • Real Name:Azrin Aris

Posted 14 May 2009 - 00:44

I'm experiencing what seems to be a couple of glitches.

When I select "Search by - Manufacturer", I get one product that shows automatically (first alphanumerical - AMT/608). Could live with that, no biggy.


I'll look into it, but I did not get the error though.

But once I select a Manufacturer, the Category column is greyed out and can't be selected. Is that supposed to function that way?


I had a problem when a same product is copied into multiple categories, it gives you some weird behavior. I've made some modification on the coming version.

I'm working on a new major upgrade and rename the mod to Quick Store Manager v 0.1.1. I had 2 modules working now - the Original Quick Stock Updater and a new Quick Price Updater. The Price update is very useful if you use SPPC. Do you want to test it for me?

There will be a total of 4 modules:

1. Stock Updater
- this is the original Quick Stock Updater

2. Price Updater
- quickly update SPPC pricing - price can be updated using the same selection criteria (finalizing the code /biggrin.gif' class='bbc_emoticon' alt=':D' />)

3. Cost Updater
- this feature was requested sometime ago and I also need it now /wink.gif' class='bbc_emoticon' alt=';)' /> - cost+shipping+tax+markup = retail price
4. Stock Reorder
- products are assigned to suppliers and reorder list si displayed. this will make easier to create purchase order to different supplier. But this would take some time as new database need to be created

#140   jhande

jhande
  • Members
  • 2,236 posts
  • Real Name:Jim Hande
  • Gender:Male
  • Location:Keene, NH USA

Posted 14 May 2009 - 05:39

I'll look into it, but I did not get the error though.

Like I said, it's no big problem for me. I just thought it was kind of weird. /rolleyes.gif' class='bbc_emoticon' alt=':rolleyes:' />



I had a problem when a same product is copied into multiple categories, it gives you some weird behavior. I've made some modification on the coming version.

Humm, I don't have any products copied to any other categories. I thought it was kind of strange that in 3.7 each product categories drop down was selectable but now it's not. /huh.gif' class='bbc_emoticon' alt=':huh:' />

The Price update is very useful if you use SPPC. Do you want to test it for me?

Ooch... I don't use SPPC. I'm also working with my live site... I know, a BIG NO, NO. /blush.gif' class='bbc_emoticon' alt=':blush:' /> But I've had problems recently with my PC and dumped Windows Server, XXAMP and a bunch of other database programs my professor had us install. Now I'm back to running normal again.

There will be a total of 4 modules:

1. Stock Updater
- this is the original Quick Stock Updater

2. Price Updater
- quickly update SPPC pricing - price can be updated using the same selection criteria (finalizing the code /biggrin.gif' class='bbc_emoticon' alt=':D' /> )

3. Cost Updater
- this feature was requested sometime ago and I also need it now /wink.gif' class='bbc_emoticon' alt=';)' /> - cost+shipping+tax+markup = retail price
4. Stock Reorder
- products are assigned to suppliers and reorder list si displayed. this will make easier to create purchase order to different supplier. But this would take some time as new database need to be created


WOW sounds like you're real busy. I'm good with just the Quick Stock Updater. /wink.gif' class='bbc_emoticon' alt=';)' />

So far it's been simple to keep track of things (even in the store). My osC site doesn't subtract product quantities.
I use zero to equal back ordered (I don't have it and neither does any of my distributors).
One product in stock equals a discontinued product (which shows on the site). Example
My distributors have either an updated Access or Excel file for me weekly which shows current stock and MSRP.
I link them to my database and spreadsheet which calculates my cost and then adds percentage markup for my selling price.
All I need to do is use your Quick Stock Updater to make changes to price and availability.
- :: Jim :: -
- My Toolbox ~ Adobe Web Bundle, XAMPP & WinMerge | Install ~ osC v2.3.3.4 -