Jump to content



Photo
* * * * * 1 votes

Adding a background image to the whole site.


This topic has been archived. This means that you cannot reply to this topic.
68 replies to this topic

#21   mirs7

mirs7
  • Members
  • 1 posts

Posted 13 December 2006 - 19:30

Ihad in the first time gotten the bg in my store through the stylesheet.css. then I wanted to chnage a color of a navigation bar and went in the Stylesheet manager. now I can not get back into my stylesheet.css under catalog. the permission are all in black and can not be changed and so is the owner name which instead of being mine now says www. Can anyone help? I want my background back.

Now I did find a stylesheet.css under /admin/includes/ that i can get into but it is not changing anything.

Thank you for any help. Kami

#22   BillinDetroit

BillinDetroit
  • Members
  • 44 posts

Posted 13 January 2007 - 07:36

my image still will not display on my site, all i get is a plain white BG and my text has changed to Times New Roman?? any suggetsions, this is the code i have
BODY {
background-image : url('/www/images/metal013.gif);
background-repeat : no-repeat;
background-position : 50% 50%;
background-attachment : fixed;
color : #000000;
margin : 0;
}



I'm no guru, but shouldn't there be a closing quote on the image url?
Wooden stuff.

#23   courtfool

courtfool
  • Members
  • 7 posts

Posted 17 November 2007 - 06:21

I removed the extra / form it and now it works great!
It it this one marked in red ('/ images/your_image.gif');

BODY {
background-image: url('images/bg_snow.jpg');
background-repeat: repeat;
background-position: center;
}

I hope that helps....Satu



I have gotten my image to appear but I am trying to creat a different effect. I am using a background .gif with transparency. but it is showing a white background behind the .gif I am using.

http://partnersiniro...n...er&Itemid=8

I am trying to be consistant with the site but having a problem with this area. does anyone have any ideas?

BODY {
background-image : url('/images/osbackground.gif');
background-repeat : repeat;
background-position : center;
background-attachment : fixed;
color : #000000;
margin : 0;
}
this is my code

#24   raybeam

raybeam
  • Members
  • 34 posts

Posted 13 April 2008 - 01:58

Great post. I managed to add a background image to my shop.. But I've encountered a new problem also..

Now it looks like this! :
[img]http://a173.ac-images.myspacecdn.com/images01/90/l_c70bd91090b8d25bdfbf6896a4f71334.jpg[/img]

as you see half of the box is transparent... Help please? /wink.gif' class='bbc_emoticon' alt=';)' />

#25   raybeam

raybeam
  • Members
  • 34 posts

Posted 13 April 2008 - 21:23

I've solved the problem. If anyone else encounters it in the future, here's the solution:
I just changd the background to #000000 in
.productListing-heading
TD.productListing-data

And then I changed border-spacing to 0px in TABLE.productListing.

Sweet /smile.gif' class='bbc_emoticon' alt=':)' />

#26   Aye Poppin

Aye Poppin
  • Members
  • 131 posts

Posted 19 April 2008 - 20:01

I have my background image but I want to reverse the repeat image. Tried a few things-any suggestions?

#27   hackia

hackia
  • Members
  • 15 posts

Posted 03 September 2008 - 06:51

Hey.

I am trying to add a background to my whole page but no matter what i do it wont work

it orginal had this

BODY {background: #ffffff; color: #000000; margin: 0px;}

.infoBox {background: #cbc9c9;}
.infoBoxContents {background: #ffffff;font-family: Verdana, Arial, sans-serif; font-size: 10px;}

i added

BODY {
background:url(ground.jpg);
background-repeat : no-repeat;
background-position : 50% 50%;
background-attachment : fixed;
color : #000000;
margin : 0;
}

i added it with and without what was originally there but no luck? It wont work.

my site is http://qqfbotique.com/Boutique/

PLEASE PLEASE ANY HELP /ohmy.gif' class='bbc_emoticon' alt=':o' />

here is my stylesheet
http://www.qqfbotiqu.../stylesheet.css

My dead line is friday /sad.gif' class='bbc_emoticon' alt=':(' />

Thanks

Edited by hackia, 03 September 2008 - 06:55.


#28   hackia

hackia
  • Members
  • 15 posts

Posted 03 September 2008 - 07:05

I TRIED PUTTING {background-image: url(images/ground.jpg);} THAT PIECE OF LINE GOOD EVRYWHERE IN MY STYLE SHEET I MEAN EVRYWHERE!!!!!!!

BUT NOPE MY BACKGROUND IS STILL WHITE

BUT LIKE ALOT OF OTHER STUFF CHANGED

BUT NOT MY BACKROUND PLEASE
I AM PULLING MY HAIR OUT AT THIS POINT

#29   germ

germ
  • Members
  • 13,921 posts

Posted 03 September 2008 - 14:38

If you either put the image in the right place, or used the correct image name it would help.
/dry.gif' class='bbc_emoticon' alt='<_<' />

The image you are trying to use doesn't exist on the site:

http://qqfbotique.co...ages/ground.jpg

Click that.
/huh.gif' class='bbc_emoticon' alt=':huh:' />
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#30   hackia

hackia
  • Members
  • 15 posts

Posted 04 September 2008 - 03:17

If you either put the image in the right place, or used the correct image name it would help.
/dry.gif' class='bbc_emoticon' alt='<_<' />

The image you are trying to use doesn't exist on the site:

http://qqfbotique.co...ages/ground.jpg

Click that.
/huh.gif' class='bbc_emoticon' alt=':huh:' />



Haha no i am working on it in my local host off xampp the image is there

iam not a to much of a newbie
but the image is definatly there

haha thanks though, u must of though oh what an idiot haha

#31   germ

germ
  • Members
  • 13,921 posts

Posted 04 September 2008 - 03:46

"idiot" didn't cross my mind.

"inexperienced" did.

If you put the image online I could possibly help.

As it is you're "flying solo".
If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."
- Me -

"Headers already sent" - The definitive help

"Cannot redeclare ..." - How to find/fix it

SSL Implementation Help

Like this post? "Like" it again over there >

#32   drumcentral

drumcentral
  • Members
  • 51 posts

Posted 11 November 2008 - 12:35

Hello All.

I'd really like to add a Flash background to the site. Does anyone know how to do this? I have Flash-enabled my site.
Or, I'd like to be able to have a different background for different sections of the site.

Thanks in advance.
--------------------------------------------------------------------------------------------------

#33   MinipainterUS

MinipainterUS
  • Members
  • 7 posts

Posted 18 November 2008 - 14:32

I have managed to change the store background, but all the "boxes" for Categories, New Products, etc are still white. How and where do I change these to my site background image?

The problem can be seen here: http://minipainter.netfirms.com/

#34   JustJack

JustJack
  • Members
  • 2 posts

Posted 22 November 2008 - 17:09

BODY {
background-image : url('images/osback.jpg');
background-repeat : repeat;
background-position : center;

background: #ffff99;
color: #000000;
margin: 0px;
}


If you have the above codes, the the background colour overides the background image. It may be simple stuff to you GENIUSES out there but I wasted an hour trying to work out why my background was not working.

JustJack is JustLearning.

#35   MinipainterUS

MinipainterUS
  • Members
  • 7 posts

Posted 01 December 2008 - 18:20

I have done this, and I have my background image in place. However, the boxes named "Categories", "What's New", and the rest of these type of boxes do not show my bg image. Is there some code line(s) I need to change to affect these areas as well? If so, where are these lines, and what should they say?

#36   deftone

deftone
  • Members
  • 2 posts

Posted 01 December 2008 - 22:56

I have done this, and I have my background image in place. However, the boxes named "Categories", "What's New", and the rest of these type of boxes do not show my bg image. Is there some code line(s) I need to change to affect these areas as well? If so, where are these lines, and what should they say?


First make a backup of your stylesheet then
find the lines that look like:

background: #F8F8F9;

and delete them all.
That should get rid of that light-grey background color in those boxes you're talking about which should allow for the page background to show "through" the table.

#37   steve_tester

steve_tester
  • Members
  • 39 posts

Posted 01 December 2008 - 23:57

can anyone let me know the code to make my site move down the browser slightly so there is a slight gap at the top of page above the header

thank you very much

#38   deftone

deftone
  • Members
  • 2 posts

Posted 02 December 2008 - 00:10

can anyone let me know the code to make my site move down the browser slightly so there is a slight gap at the top of page above the header

thank you very much



in your stylesheet.css file
add this to the BODY class:

margin-top: 20px;


or
replace the default store_logo.png with your own logo and in your logo, leave some "white space" at the top.

#39   potterymonster

potterymonster
  • Members
  • 3 posts

Posted 28 January 2009 - 01:47

I cannot get my site to show the background. I have done the changes that I have read about but it still shows only white. Someone help? Thanks!
My site is polishpotterystore.com/catalog

#40   Stroker396

Stroker396
  • Members
  • 83 posts

Posted 07 March 2009 - 05:00

just subscribing, adding this later.
The Site can be viewed at www.performanceautopartsonline.com

The site is live (despite these minor glitches) please respect that and do not sign up etc...

maybe a contribution one day when I get this site the way I want it.

I don't make spelling mistakes! I have dyslecsic fingers.