Jump to content



- - - - -

Automated FedEx Labels


  • Please log in to reply
713 replies to this topic

#21   Stormer

Stormer
  • Members
  • 6 posts
  • Real Name:James

Posted 02 September 2004 - 09:29 PM

Hello,

I've installed this contrib and get everything to work now "except" I can't see the actual "label" to even get a plain paper print out.

I get the fedex tracking number.  It puts the order in delivered...  (which I'll change to shipped, thanks to an earlier post)

But basically, when I enter in how many lbs, on the next screen that should show me the label to print, it's a broken image.

Could that be a problem with curl or something else?  Maybe I'm just goofed somewhere?  Probably the case, as it appears according to the rest of the post everyone else can at least "see" the label.

<sigh>

Thanks for your input!

James

Edited by Stormer, 02 September 2004 - 09:30 PM.

Speer's 1st Law of Proofreading:
The visibility of an error is inversely proportional to the
number of times you have looked at it.

#22   Stormer

Stormer
  • Members
  • 6 posts
  • Real Name:James

Posted 02 September 2004 - 09:43 PM

Hello,

Just a follow up on my last post...


I just went and did it again.  The png image is attempting to load from:

MYDOMAIN.COM/catalog/admin/images/fedex/462105310000033.png

So.. I went to that directory to see if anything was in it.   I do see a text file called: post.txt

that file contains all the shipping information.   Possibly the problem lay with my server not being able to generate a png file?  I'm really not sure what that post.txt file has to do with anything.  I'm guessing here.

Thanks again for any input you might have.

James

Edited by Stormer, 02 September 2004 - 09:44 PM.

Speer's 1st Law of Proofreading:
The visibility of an error is inversely proportional to the
number of times you have looked at it.

#23   Stormer

Stormer
  • Members
  • 6 posts
  • Real Name:James

Posted 02 September 2004 - 11:06 PM

Hello All,

Another follow up on previous post.

It's FIXED.   :rolleyes:

After corresponding with SteveC, he asked me to make sure the /admin/images/fedex was chmodded 777.  When I went in, I noticed these images in the /admin

Aug 25 12:25 DIR_WS_FEDEX_LABELS462105310000002.png
Aug 25 12:26 DIR_WS_FEDEX_LABELS462105310000019.png
Sep  2 17:17 DIR_WS_FEDEX_LABELS462105310000026.png
Sep  2 17:38 DIR_WS_FEDEX_LABELS462105310000033.png

he simply told me:

edit:
catalog/admin/includes/configure.php and add the following lines some
where before the ending  ?>

// fedex BOF
define('DIR_WS_FEDEX_LABELS', DIR_WS_IMAGES . 'fedex/');
// fedex EOF


It all works now.

This contrib was a bear to install in the first place, I am not at all surprised I missed this in the instructions.  Or, maybe it wasn't in the instructions at all..LOL  (that is doubtful since no one else was having this problem)   But this was the fix.

thanks all.

James
Speer's 1st Law of Proofreading:
The visibility of an error is inversely proportional to the
number of times you have looked at it.

#24   ringman57

ringman57
  • Members
  • 10 posts
  • Real Name:Anthony DeSalvatore

Posted 09 September 2004 - 02:37 PM

I'm going through the code, trying to figure this out, one line is confusing to me
// create new FedExDC object
$fed = new FedExDC($shipVars[0][10],$shipVars[1][498]);

Where does $shipVars get its values from? I dont see where its built....

Thanks!

#25   wendys

wendys
  • Members
  • 108 posts
  • Real Name:Wendy

Posted 12 September 2004 - 09:07 AM

Thanks Michael for this great contribution.  It is really a life savor.   :lol:

We use Fedex almost exclusively to ship and this contribution really saves lots of time on generating shipping labels.

I do have one question though.  I noticed that this contribution is for Daily pickup only.  Is that possible to add a "drop off" option so that people can have more flexbility.  

The installation did take me a while.  Your instruction is really easy to follow.

Thanks.

Wendy

#26   johnnymke

johnnymke
  • Members
  • 104 posts
  • Real Name:Johnny
  • Gender:Male
  • Location:Milwaukee

Posted 15 September 2004 - 08:26 PM

Ive had problems getting approval to move to the production server from FedEx. They claim the barcode is not within their dimensions. Also, when I use the 'Print Page' feature in fedex_popup.php, my print result is black, like it was inverted...

Anyone else run into problems getting certification with FedEx?

#27   spoot

spoot
  • Members
  • 199 posts
  • Real Name:michael

Posted 15 September 2004 - 08:43 PM

johnnymke, on Sep 15 2004, 08:26 PM, said:

Ive had problems getting approval to move to the production server from FedEx. They claim the barcode is not within their dimensions. Also, when I use the 'Print Page' feature in fedex_popup.php, my print result is black, like it was inverted...

Anyone else run into problems getting certification with FedEx?
You'll need to compare the label you're printing to a standard FedEx label, & make sure it's printing to the right size. This will depend on your printer & monitor... but in any case, you adjust the size of the printed label on line 63 of fedex_popup.php:

var resolution = 96;

Try changing that to 64 or 128, or anything else for that matter. Smaller number prints bigger, bigger number prints smaller (I think).

I'm not sure about the printing black/printing inverted problem. I don't believe a browser can have that kind of impact on a printer; and whether you click the "print" button, Ctrl+p, or File/Print, it's all the same to your system.

#28   ringman57

ringman57
  • Members
  • 10 posts
  • Real Name:Anthony DeSalvatore

Posted 17 September 2004 - 05:44 PM

Works just fine for a single package, however for multiple I get the following error returned:

This transaction could not be completed. Please note the error message below.

ERROR: FedEx Return Error 1219 : Invalid package count or package sequence exceeds package count

Running in debug mode I get this:

Shipment request data, package #1:

Array
(
    [0] => 21
    [16] => PA
    [13] => 114  drive
    [1273] => 01
    [1274] => 05
    [18] => 5555551212
    [15] => atown
    [23] => 01
    [117] => US
    [17] => 18104
    [50] => US
    [11] => 
    [12] => Anthony DeSalvatore
    [1333] => 1
    [1415] => 400.00
    [1368] => 2
    [1369] => 1
    [1370] => 5
    [24] => 20040920
    [25] => 
    [1119] => Y
    [440] => N
    [10] => 237466381
    [498] => 1041931
    [75] => LBS
    [4] => Rfm.com
    [5] => 420  Road
    [6] => NONE
    [7] => Wst Hn
    [8] => CT
    [9] => 00562
    [183] => 5555551212
    [68] => USD
    [116] => 2
    [1117] => 1
    [1400] => 2.0
    [1401] => 1.0
)

Manifest data, package #1:

Array
(
    [delivery_id] => 
    [orders_id] => 282
    [delivery_name] => Anthony DeSalvatore
    [delivery_company] => 
    [delivery_address_1] => 114 drive
    [delivery_address_2] => 
    [delivery_city] => atown
    [delivery_state] => PA
    [delivery_postcode] => 18104
    [delivery_phone] => 5555551212
    [package_value] => 400
    [oversized] => 0
    [pickup_date] => 20040920
    [shipping_type] => 05
    [residential] => N
    [cod] => 
    [multiple] => 1
    [package_weight] => 1.0
    [tracking_num] => master_trackNum
)

Shipment request data, package #2:

Array
(
    [0] => 21
    [16] => PA
    [13] => 114 drive
    [1273] => 01
    [1274] => 05
    [18] => 5555551212
    [15] => atown
    [23] => 01
    [117] => US
    [17] => 18104
    [50] => US
    [11] => 
    [12] => Anthony DeSalvatore
    [1333] => 1
    [1415] => 400.00
    [1368] => 2
    [1369] => 1
    [1370] => 5
    [24] => 20040920
    [25] => 
    [1119] => Y
    [440] => N
    [10] => 237466381
    [498] => 1041931
    [75] => LBS
    [4] => rf.com
    [5] => 420 Road
    [6] => NONE
    [7] => Wen
    [8] => CT
    [9] => 00252
    [183] => 5555551212
    [68] => USD
    [116] => 2
    [1117] => 2
    [1400] => 2.0
    [1401] => 1.0
    [1123] => master_trackNum
)

Manifest data, package #2:

Array
(
    [delivery_id] => 
    [orders_id] => 282
    [delivery_name] => Anthony DeSalvatore
    [delivery_company] => 
    [delivery_address_1] => 114 drive
    [delivery_address_2] => 
    [delivery_city] => atown
    [delivery_state] => PA
    [delivery_postcode] => 18104
    [delivery_phone] => 5555551212
    [package_value] => 400
    [oversized] => 0
    [pickup_date] => 20040920
    [shipping_type] => 05
    [residential] => N
    [cod] => 
    [multiple] => 2
    [package_weight] => 1.0
    [tracking_num] => trackNum
)

running in debug mode, no ship request made

Posted data looks o.k.... anyone else get this error, or have any ideas?

#29   bbeban

bbeban
  • Members
  • 16 posts
  • Real Name:Bob Beban

Posted 02 October 2004 - 06:01 AM

Hello,

I have added this module and i am getting the following error when i attempt to ship a package:

ERROR: FedEx Return Error 1F30 : Recipient Phone must be 10 digits

Now, the only phone numbers i have in here are 10 digits. I have Real Time Quotes, it works, I have a meter number... Any idea how i can get past this and ship packages?

Thanks --

#30   spoot

spoot
  • Members
  • 199 posts
  • Real Name:michael

Posted 02 October 2004 - 01:47 PM

bbeban, on Oct 2 2004, 06:01 AM, said:

Hello,

I have added this module and i am getting the following error when i attempt to ship a package:

ERROR: FedEx Return Error 1F30 : Recipient Phone must be 10 digits

Now, the only phone numbers i have in here are 10 digits. I have Real Time Quotes, it works, I have a meter number... Any idea how i can get past this and ship packages?

Thanks --

<{POST_SNAPBACK}>



What format are your phone numbers in? Meaning: (123) 456 - 2569 or 123.456.2569 etc.

#31   bbeban

bbeban
  • Members
  • 16 posts
  • Real Name:Bob Beban

Posted 03 October 2004 - 05:39 AM

spoot, on Oct 2 2004, 01:47 PM, said:

What format are your phone numbers in? Meaning: (123) 456 - 2569 or 123.456.2569 etc.

<{POST_SNAPBACK}>


The numbers are in 1234567890

#32   spoot

spoot
  • Members
  • 199 posts
  • Real Name:michael

Posted 03 October 2004 - 02:14 PM

bbeban, on Oct 3 2004, 05:39 AM, said:

The numbers are in 1234567890

<{POST_SNAPBACK}>


If you could, switch to debug mode (option is at the top of ship_fedex.php) & post the output here.

Thanks -

Michael

#33   bbeban

bbeban
  • Members
  • 16 posts
  • Real Name:Bob Beban

Posted 04 October 2004 - 05:46 AM

spoot, on Oct 3 2004, 02:14 PM, said:

If you could, switch to debug mode (option is at the top of ship_fedex.php) & post the output here.

Thanks -

Michael

<{POST_SNAPBACK}>

Here's the output, altered for privacy purposes:

Shipment request data, package #1:

Array
(
    [0] => 21
    [16] => NV
    [13] => 1234 Versailles Ct
    [1273] => 01
    [1274] => 92
    [18] => 702 1234567
    [15] => City
    [23] => 01
    [117] => US
    [17] => 89999
    [50] => US
    [11] => Empro
    [12] => John Smith
    [1333] => 1
    [1415] => 5.00
    [1368] => 2
    [1369] => 1
    [1370] => 5
    [24] => 20041004
    [1119] => Y
    [440] => N
    [3124] => 2
    [10] => 275692547
    [498] => 3987654
    [75] => LBS
    [4] => www.websitename.com
    [5] => 11222 NameOf Street
    [6] => NONE
    [7] => Las Vegas
    [8] => NV
    [9] => 89135
    [183] => 7021234567
    [68] => USD
    [1401] => 4.0
)

Manifest data, package #1:

Array
(
    [delivery_id] =>
    [orders_id] => 766
    [delivery_name] => John Smith
    [delivery_company] =>
    [delivery_address_1] => 1234 Versailles Ct
    [delivery_address_2] =>
    [delivery_city] => City
    [delivery_state] => NV
    [delivery_postcode] => 89074
    [delivery_phone] => 702 123-4567
    [package_weight] =>
    [package_value] => 5
    [oversized] => 2
    [pickup_date] => 20041004
    [shipping_type] => 92
    [residential] => N
    [cod] =>
    [tracking_num] => master_trackNum
)

running in debug mode, no ship request made

That phone number format is not the same as what i have in the DB... which is interesting...

#34   spoot

spoot
  • Members
  • 199 posts
  • Real Name:michael

Posted 04 October 2004 - 05:51 AM

bbeban, on Oct 4 2004, 05:46 AM, said:

[18] => 702 1234567

That phone number format is not the same as what i have in the DB... which is interesting...

<{POST_SNAPBACK}>


Yeah - that's where the problem is, the space after the area code. What do you have for the number in the database?

#35   bbeban

bbeban
  • Members
  • 16 posts
  • Real Name:Bob Beban

Posted 04 October 2004 - 06:02 AM

spoot, on Oct 4 2004, 05:51 AM, said:

Yeah - that's where the problem is, the space after the area code. What do you have for the number in the database?

<{POST_SNAPBACK}>


The number in the cutomers table is right, but the orders table has it wrong... will adjust now.

Ok, I adjusted it and now it works. Is it supposed to take me to the admin main login page and force me to login again after i ship an order? That was weird...

#36   bbeban

bbeban
  • Members
  • 16 posts
  • Real Name:Bob Beban

Posted 05 October 2004 - 05:47 AM

Am I supposed to get sent to the admin main login page and forced to login again after i ship an order?

This also happens when I click the "Fedex label" button or the "cancel shipment" button. Any suggestions?

#37   bbeban

bbeban
  • Members
  • 16 posts
  • Real Name:Bob Beban

Posted 05 October 2004 - 05:54 AM

I meant to say in my post above:
--------------------------------------
Am I supposed to get sent to the admin main login page and forced to login again after i ship an order?

This also happens when I click the "Fedex label" button, the "cancel shipment" button, or the "back" button -- the back button that appears on the "track shipment" page.

Any suggestions?

Thanks --

#38   render

render
  • Members
  • 2 posts
  • Real Name:Jon

Posted 09 October 2004 - 05:10 PM

I was added to the test server and I still get this error

This transaction could not be completed. Please note the error message below.

ERROR: FedEx Return Error 5012 : Account number not in database

any ideas?? Im sure I just missed a step...but where?

#39   spoot

spoot
  • Members
  • 199 posts
  • Real Name:michael

Posted 09 October 2004 - 10:09 PM

render, on Oct 9 2004, 05:10 PM, said:

I was added to the test server and I still get this error

This transaction could not be completed. Please note the error message below.

ERROR: FedEx Return Error 5012 : Account number not in database

any ideas?? Im sure I just missed a step...but where?

<{POST_SNAPBACK}>


Which server to use is defined on line 3 of admin/includes/fedexdc.php; this needs to be set to "test."

Erm... otherwise, I'm not sure where to look. Check that and see what happens. You might also just have to wait a bit, or hassle fedex & make sure they're not pulling your chain...

#40   render

render
  • Members
  • 2 posts
  • Real Name:Jon

Posted 11 October 2004 - 04:58 AM

spoot, on Oct 9 2004, 05:09 PM, said:

Which server to use is defined on line 3 of admin/includes/fedexdc.php; this needs to be set to "test."

Erm... otherwise, I'm not sure where to look. Check that and see what happens. You might also just have to wait a bit, or hassle fedex & make sure they're not pulling your chain...

<{POST_SNAPBACK}>


Its defined as test, I read somthing about a subscription request...might that be it?