Jump to content



- - - - -

smtp email send problem


This topic has been archived. This means that you cannot reply to this topic.
4 replies to this topic

#1   banderaz

banderaz
  • Members
  • 26 posts

Posted 06 October 2007 - 06:01 PM

Hi,

osc 2,2rc1
win 2000 box
apachefriends/xampp

"Out of the box" install, and can't send email. Changed in admin to "smtp" and just a email-adress in the "from" field. (Found theese two in other post here)
Edit 3 files named php.ini, and replaced "localhost" with smtp.myisp.com (with an actuall adress ofcourse) :)
php.ini found and editet from thise path:
c:/xampp/apache/bin
c:/xampp/php
c:/xampp/php/php4

This is the error I get when a customer buy something, and do the checkout, and if I try to send email to a customer from admin:

Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\xampp\htdocs\catalog\admin\includes\classes\email.php on line 520

Warning: Cannot modify header information - headers already sent by (output started at C:\xampp\htdocs\catalog\admin\includes\classes\email.php:520) in C:\xampp\htdocs\catalog\admin\includes\functions\general.php on line 22

Really hope there is a simple solution to this :)
Thank you

#2   bpopelar

bpopelar
  • Members
  • 324 posts

Posted 06 October 2007 - 06:30 PM

I'm not certain the SMTP based email works out of the box (I never tried to get it working out of the box).  The sendmail based email does work on the baseline distribution, but this mode is of no use on a Windows based platform.

You need to load the SMTP Authentication contribution (http://www.oscommerce.com/community/contributions,901) to correctly support SMTP based email with or without password authentication.

There is an official support thread for this contribution which can be found at http://forums.oscommerce.com/index.php?showtopic=274251.

You might also look at the posting http://forums.oscommerce.com/index.php?showtopic=278981 for a sample configuration

Ben

Edited by bpopelar, 06 October 2007 - 06:35 PM.


#3   banderaz

banderaz
  • Members
  • 26 posts

Posted 06 October 2007 - 06:35 PM

I suddenly found a post (among many many email problem posts...)

I edit configure.php in /catalog/includes and /catalog/admin/includes

At the bottom of both files, I add the following

ini_set("SMTP","smtp.myisp.com"); 
  ini_set("smtp_port","25");
  ini_set("sendmail_from","storeowner@store.com");

(With real names/adresses)

Works like a charm! No need to add any extra modules etc.

#4   dennitzio

dennitzio
  • Members
  • 4 posts

Posted 30 November 2007 - 02:00 AM

View Postbanderaz, on Oct 6 2007, 10:35 AM, said:

I suddenly found a post (among many many email problem posts...)

I edit configure.php in /catalog/includes and /catalog/admin/includes

At the bottom of both files, I add the following

ini_set("SMTP","smtp.myisp.com"); 
  ini_set("smtp_port","25");
  ini_set("sendmail_from","storeowner@store.com");

(With real names/adresses)

Works like a charm! No need to add any extra modules etc.

Dude, I love you. You made my year.

#5   tharsoe

tharsoe
  • Members
  • 1 posts

Posted 19 August 2008 - 02:14 AM

Hi Bjorn Gronland

I create like ur. but I got an error

Quote

Warning: mail() [function.mail]: Failed to connect to mailserver at "smtp.xxx.sg" port 465, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\xampp\htdocs\confirm\index.php on line 43

How can I solve, pls help me?